POJ 3268(正反向dijkstra)

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题意:(直接复制过来了)
给出n个点和m条边,接着是m条边,代表从牛a到牛b需要花费c时间,现在所有牛要到牛x那里去参加聚会,并且所有牛参加聚会后还要回来,给你牛x,除了牛x之外的牛,他们都有一个参加聚会并且回来的最短时间,从这些最短时间里找出一个最大值输出
思路:首先求单源最短边用dijkstra就可以了,但是这道题求的是从x到n加上从n到x,这道题是有向边,所以你需要先求出从x到各个边距离,然后交换任意两边的距离,再次求x到其它边的最短距离就行,最后加一下就是答案

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<math.h>
#define M 1005
#define inf 99999999
using namespace std;
int dis1[M],dis2[M],vis[M],mapp[M][M];
int n,m,x;
int main()
{
    scanf("%d%d%d",&n,&m,&x);
    int u,v,w;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(i==j)
                mapp[i][j]=0;
            else
                mapp[i][j]=inf;
        }
    }
    for(int a=1;a<=m;a++)
    {
        scanf("%d%d%d",&u,&v,&w);
        mapp[u][v]=min(mapp[u][v],w);
    }
    for(int a=1;a<n;a++)
        vis[a]=0;
    vis[x]=1;
    for(int a=1;a<=n;a++)
      dis1[a]=mapp[x][a];
    for(int i=1;i<=n-1;i++)
    {
        int minn=inf,k;
        for(int j=1;j<=n;j++)
        {
          if(dis1[j]<minn&&vis[j]==0)
          {
              minn=dis1[j];
              k=j;
          }
        }
        vis[k]=1;
        for(int a=1;a<=n;a++)
        {
            if(mapp[k][a]<inf)
            dis1[a]=min(dis1[a],dis1[k]+mapp[k][a]);
        }
    }

    for(int i=1;i<=n;i++)
    {
        for(int j=i;j<=n;j++)
        {
            swap(mapp[i][j],mapp[j][i]);  //交换两点之间距离,不能让j=1开始,否则的话就会交换两次又变回原来的距离
        }
    }
    for(int a=1;a<=n;a++)
      dis2[a]=mapp[x][a];
    for(int a=1;a<=n;a++)
        vis[a]=0;
    vis[x]=1;

    for(int i=1;i<=n-1;i++)
    {
        int minn=inf,k;
        for(int j=1;j<=n;j++)
        {
          if(dis2[j]<minn&&vis[j]==0)
          {
              minn=dis2[j];
              k=j;
          }
        }
        vis[k]=1;
        for(int a=1;a<=n;a++)
        {
          dis2[a]=min(dis2[a],dis2[k]+mapp[k][a]);
        }
    }
    int ans=0;
    for(int a=1;a<=n;a++)
    {
        ans=max(ans,dis1[a]+dis2[a]);
    }
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值