6-4 链式表的按序号查找 (10 分)

本题要求实现一个函数,找到并返回链式表的第K个元素。

函数接口定义:

ElementType FindKth( List L, int K );

其中List结构定义如下:

typedef struct LNode *PtrToLNode;
struct LNode {
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode List;

L是给定单链表,函数FindKth要返回链式表的第K个元素。如果该元素不存在,则返回ERROR。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define ERROR -1
typedef int ElementType;
typedef struct LNode *PtrToLNode;
struct LNode {
    ElementType Data;
    PtrToLNode Next;
};
typedef PtrToLNode List;

List Read(); /* 细节在此不表 */

ElementType FindKth( List L, int K );

int main()
{
    int N, K;
    ElementType X;
    List L = Read();
    scanf("%d", &N);
    while ( N-- ) {
        scanf("%d", &K);
        X = FindKth(L, K);
        if ( X!= ERROR )
            printf("%d ", X);
        else
            printf("NA ");
    }
    return 0;
}

/* 你的代码将被嵌在这里 */

输入样例:

1 3 4 5 2 -1
6
3 6 1 5 4 2

输出样例:

4 NA 1 2 5 3

AC:

ElementType FindKth( List L, int K ){
    int x = 1;
    if(K <= 0)
        return -1;
        while(L!=NULL){
            if(x == K){
                return L->Data;
            }
            x++;
            L = L->Next;
        }
        return -1;
}

WA:

ElementType FindKth( List L, int K ){
    int x = 0;
    if(K <= 0)
        return -1;
        while(L!=NULL){
            x++;
            L = L->Next;
            if(x == K){
                return L->Data;
            }
        }
        return -1;
}

WA

a.c: In function ‘FindKth’:
a.c:56:5: warning: this ‘if’ clause does not guard… [-Wmisleading-indentation]
if(K <= 0)
^~
a.c:58:9: note: …this statement, but the latter is misleadingly indented as if it is guarded by the ‘if’
while(L!=NULL){
^~~~~
a.c: In function ‘Read’:
a.c:20:2: warning: ignoring return value of ‘scanf’, declared with attribute warn_unused_result [-Wunused-result]
scanf("%d", &X);
^~~~~~~~~~~~~~~
a.c:28:3: warning: ignoring return value of ‘scanf’, declared with attribute warn_unused_result [-Wunused-result]
scanf("%d", &X);
^~~~~~~~~~~~~~~
a.c: In function ‘main’:
a.c:40:5: warning: ignoring return value of ‘scanf’, declared with attribute warn_unused_result [-Wunused-result]
scanf("%d", &N);
^~~~~~~~~~~~~~~
a.c:42:9: warning: ignoring return value of ‘scanf’, declared with attribute warn_unused_result [-Wunused-result]
scanf("%d", &K);
^~~~~~~~~~~~~~~


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值