PTA 银行业务队列简单模拟 (25 分)

这篇博客探讨了如何解决银行窗口排队问题,其中A窗口处理速度是B窗口的两倍。提供了两种错误(WA)和已通过(AC)的C++代码实现,分别使用了队列数据结构来模拟窗口处理过程。AC代码中,首先处理A窗口的顾客,然后交替处理A和B窗口,确保在处理完相同数量的顾客时,A窗口的顾客优先输出。
摘要由CSDN通过智能技术生成
  • 设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。

输入格式:

  • 输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。

输出格式:

按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。


输入样例:

8 2 1 3 9 4 11 13 15
结尾无空行

输出样例:

1 3 2 9 11 4 13 15
结尾无空行

WA:

/* -------- PTA ---------
   银行窗口排队问题,数组方法 ?????
   需要答疑!!!
*/
#include <bits/stdc++.h>
using namespace std;
int main()
{
    std::ios_base::sync_with_stdio(false);
    int n;
    cin >> n;
    int *a = new int[n + 1];
    queue<int> q1, q2;
    for (int i = 1; i <= n; i++)
    {
        cin >> a[i];
        if (a[i] % 2 != 0)
            q1.push(a[i]);
        if (a[i] % 2 == 0)
            q2.push(a[i]);
    }
    // while(!q1.empty())
    // {
    //     cout << q1.front() << " ";
    //     q1.pop();
    // }
    // cout << endl;
    // while(!q2.empty())
    // {
    //     cout << q2.front() << " ";
    //     q2.pop();
    // }
    int cnt = n;
    while (cnt != 0)
        if (cnt % 3 != 0)
        {
            cout << q1.front() << " ";
            q1.pop();
            cnt--;
        }
        if (cnt % 3 == 0)
        {
            cout << q2.front() << " ";
            q2.pop();
            cnt--;
        }
    delete (a);
    return 0;
}

PE:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    std::ios_base::sync_with_stdio(false);
    queue<int> q1, q2;
    int n;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        int tmp;
        cin >> tmp;
        if (tmp % 2 != 0)
            q1.push(tmp);
        else if (tmp % 2 == 0)
            q2.push(tmp);
    }
/*  cout << "输出q1队列:" << endl;
    while(!q1.empty())
    {
        cout << " " << q1.front();
        q1.pop();
    }
    cout << endl;
    cout << "输出q2队列:" << endl;
    while(!q2.empty())
    {
        cout << " " << q2.front();
        q2.pop();
    }
    cout << endl;
*/
    //输出首个元素
    if (!q1.empty())
    {
        cout << q1.front();
        q1.pop();
    }
    int cnt = 1;
    while (!q1.empty() || !q2.empty())
    {
        cnt++;
        if (!q1.empty())
        {
            cout << " " << q1.front();
            q1.pop();
        }
        if (!q2.empty() && cnt % 2 == 0)
        {
            cout << " " << q2.front();
            q2.pop();
        }
    }
    return 0;
}

PE


AC:

[1]

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    cin >> n;
    queue<int> q1, q2;
    for (int i = 0; i < n; i++)
    {
        int tmp;
        cin >> tmp;
        if (tmp % 2 == 0)
            q2.push(tmp);
        else
            q1.push(tmp);
    }
    int cnt = 0;
    while (1)
    {
        if (q1.size() > 0)
        {
            if (cnt == 0)
            {
                cout << q1.front();
                q1.pop();
            }
            else
            {
                cout << " " << q1.front();
                q1.pop();
            }
            cnt++;
        }
        if (q1.size() > 0)
        {
            cout << " " << q1.front();
            q1.pop();
        }
        if (q2.size() > 0)
        {
            if (cnt == 0)
            {
                cout << q2.front();
                q2.pop();
            }
            else
            {
                cout << " " << q2.front();
                q2.pop();
            }
        }
        if ((q1.size() == 0) && (q2.size() == 0))
            break;
    }
    cout << endl;
    return 0;
}

[2]

#include <bits/stdc++.h>
using namespace std;
int main()
{
    std::ios_base::sync_with_stdio(false);
    queue<int> q1, q2;
    int n;
    cin >> n;
    int m;
    for (int i = 1; i <= n; i++)
    {
        cin >> m;
        if (m % 2 != 0)
            q1.push(m);
        if (m % 2 == 0)
            q2.push(m);
    }
    while (!q1.empty())
    {
        int cnt = 2, i = 0;
        while (cnt-- && !q1.empty())
        {
            if (i++)
                cout << " ";
            cout << q1.front();
            q1.pop();
        }
        if (!q2.empty())
        {
            cout << " " << q2.front() << " ";
            q2.pop();
        }
    }
    int i = 0;
    while (!q2.empty())
    {
        if (i++)
            cout << " ";
        cout << q2.front();
        q2.pop();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值