- 本题要求实现两个函数,分别将读入的数据存储为单链表、将链表中偶数值的结点删除。链表结点定义如下:
struct ListNode {
int data;
struct ListNode *next;
};
- 函数接口定义:
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
-
函数
createlist
从标准输入读入一系列正整数,按照读入顺序建立单链表。当读到−1
时表示输入结束,函数应返回指向单链表头结点的指针。 -
函数deleteeven将单链表head中偶数值的结点删除,返回结果链表的头指针。
- 裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
struct ListNode {
int data;
struct ListNode *next;
};
struct ListNode *createlist();
struct ListNode *deleteeven( struct ListNode *head );
void printlist( struct ListNode *head )
{
struct ListNode *p = head;
while (p) {
printf("%d ", p->data);
p = p->next;
}
printf("\n");
}
int main()
{
struct ListNode *head;
head = createlist();
head = deleteeven(head);
printlist(head);
return 0;
}
/* 你的代码将被嵌在这里 */
- 输入样例:
1 2 2 3 4 5 6 7 -1
结尾无空行
- 输出样例:
1 3 5 7
结尾无空行
- AC:
typedef struct ListNode *List;
struct ListNode *createlist()
{
List head = NULL, tail = NULL;
int n;
scanf("%d", &n);
while(n != -1)
{
List temp = (List)malloc(sizeof(List));
temp->data = n;
temp->next = NULL;
if(tail == NULL)
head = tail = temp;
else
{
tail->next = temp;
tail = temp;
}
scanf("%d", &n);
}
return head;
}
struct ListNode *deleteeven(struct ListNode *head)
{
List newhead = NULL, p = head, tail;
while(p)
{
if((p->data) % 2 != 0)
{
List temp = (List)malloc(sizeof(List));
temp->data = p->data;
temp->next = NULL;
if(newhead == NULL)
newhead = tail = temp;
else
{
tail->next = temp;
tail = temp;
}
}
p = p->next;
}
return newhead;
}