区间dp【】

题目

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input

Input contains multiple cases. Each case consists of two lines: 
The first line contains string A. 
The second line contains string B. 
The length of both strings will not be greater than 100. 

Output

A single line contains one integer representing the answer.

Sample Input

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output

6
7

Sponsor

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1100][1100],ans[1100];
char a[1100],b[1100];
int dfs(int s,int r)
{
	int i,j;
	if(dp[s][r]!=-1) return dp[s][r];
	if(s==r) return 1;
	if(s>r) return 0;
	dp[s][r]=dfs(s,r-1)+1;/*b[r]自己形成一个区间代价肯定为一*/
	for(i=s; i<r; i++)
	{
		if(b[i]==b[r])/*b[r]跟前面b[i]中跟自己相等的字母组成一个区间求最小值*/
			dp[s][r]=min(dp[s][r],dfs(s,i-1)+dfs(i,r-1));
	}
	return dp[s][r];
}
int main()
{
	int n,m,j,i,L;
	while(~scanf("%s %s",a+1,b+1))
	{
		memset(dp,-1,sizeof(dp));
		memset(ans,0,sizeof(ans));
		L=strlen(a+1);
		dfs(1,L);
		/*for(i=1;i<=L;i++)
		{
			for(j=1;j<=L;j++)
			printf("%4d",dp[i][j]);
			printf("\n");
		}*/
		for(i=1; i<=L; i++)
		{
			ans[i]=dfs(1,i);/*表示直接将a[i]转化成b[i]的最小代价*/
			if(a[i]==b[i]) ans[i]=ans[i-1];/*a[i]处不用改跟前面一样*/
			for(j=1; j<i; j++)
				ans[i]=min(ans[i],ans[j]+dfs(j+1,i));/*ans[i]的值可能让dfs(1,j)变得更小了
			最小值也就得重新比一下*/
		}
		printf("%d\n",ans[L]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值