H - Cleaning Shifts POJ - 2376 (区间覆盖)

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct pp
{
	int l,r;
} q[1101340];
bool cmp(pp x,pp y)
{
	if(x.l==y.l ) return x.r>y.r;
	else return x.l < y.l;
}
int main()
{
	int n,m,j,f,sum,right,max1,i;
	scanf("%d %d",&n,&m);
	for(i=1; i<=n; i++)
	{
		scanf("%d %d",&q[i].l,&q[i].r);
		q[i].r++;/*区间可以不连续如1~7,8~10为了防止查找遗漏,没个查询区间再多往后查一位*/
	}
	sort(q+1,q+1+n,cmp);
	right=1;
	sum=0;
	for(i=1; i<=n; i++)
	{
		f=0;
		max1=-1;
		while(q[i].l<=right&&i<=n) f=1,max1=max(max1,q[i].r),i++;/*尽量找在与上一个区间重叠的情况下覆盖最远的区间*/
		i--;/*for循环里还会加一不减的话会跳过*/
		
		if(!f)	break;
		
		if(max1>right)/*区间断开*/
		{
			right=max1;
			sum++;
		}
		
		else break;
		
		if(right>=m+1)
			break;
	}
	if(right>=m+1)
		printf("%d",sum);
	else
		printf("-1");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值