B - Cleaning Shifts POJ - 2376 区间长度贪心


Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2



题意:

给定n和t,t代表大区间右端点的值,大区间左端点为1,接着给n个小区间,给定每个小区间的左端点和右端点,问你最少使用多少个小区间能把给定的大区间覆盖


具体:令begin为当前未被覆盖的区间起点。

            贪心策略:选取包含点begin的区间中右端点最大的那个

证明:因为begin为未被覆盖的区间起点,所以begin一定要被小区间覆盖,将最优解中覆盖begin的小区间命名为区间X。

            以下使用剪贴技术证明。

            若存在包含begin的小区间Y( Y != X )使最终所需的小区间数少于原最优解,那么Y一定包含了X之后的某些小区间,

            即Y的右端点大于X的右端点,与贪心策略矛盾,得证。








#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <set>
#include <map>
#include <stack>
#include <string>
using namespace std;

int cmp(pair<int,int>a,pair<int,int>b)
{
	return a.first < b.first;
}
int main()
{
    	int n,t;
    	cin >> n >> t;
    	vector<pair<int,int> >v;
    	for(int i = 0;i < n;i++)
    	{
    		int x,r;
    		cin >> x >> r;
    			pair<int,int>p;
    		    p.first = x;
    		    p.second = r;
    		    v.push_back(p);
    	}
    	sort(v.begin(),v.end(),cmp);
    	if(v[0].first != 1)
    	{
    		cout << -1 << endl;
    		return 0;
    	}
    	int cnt = 0;///最少区间数
    	int right = 0;///已覆盖区间右端点
    	int top = 0;///集合首
    	while(right < t)
    	{
    		///选出包含begin区间中右端点最大的那个
           int be = right+1;///待覆盖的起点
           for(int i = top;i < v.size();i++)
           {
           	if(v[i].first <= be && v[i].second >= be)
           	{
           		right = v[i].second > right?v[i].second:right;
           	}
           	else if(v[i].first > be)
           	{
           		top = i;/// 不能覆盖起始点,说明上一头牛的终点就是最远点,需要换一头牛了
           		break;
           	}
           }
           if(be > right)break;
           else cnt++;
    	}
        if(right < t)
        	cout << -1 << endl;
        else
        cout << cnt << endl;
	return 0;
}










  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值