Cleaning Shifts POJ - 2376

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input
* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
Output
* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
Sample Input
3 10
1 7
3 6
6 10
Sample Output
2
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:有n头牛,每头牛的工作时间是从x到y,问你是否可以选择其中的若干头牛,使它们的工作时间排满时间1到t;

若存在,输出最少需要选择的牛的数量;若无解,输出-1.

本来以为是个并查集,但一看没法输出数量,转而想到了贪心策略,刚开始怎么贪心可是想懵逼了。

思路:首先进行排序,按照工作结束时间由早到晚,如果结束时间相同,起始时间早的优先;

         设b为当前未覆盖区间的初始点,每次选择包含b的区间中结束时间最晚的牛,如果没有选择,那么无解输出-1.


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    int x;
    int y;
};
node op[25001];
bool cmp(node a,node b)
{
    if(a.y == b.y) return a.x < b.x;
    return a.y < b.y;
}
int main()
{

    int n,t;
    while(scanf("%d%d", &n,&t) != EOF)
    {
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d", &op[i].x, &op[i].y);
            if(op[i].x < 1) op[i].x = 1;
            if(op[i].y > t) op[i].y = t;
        }
        sort(op+1, op+1+n, cmp);
        int sum = 0;
        int flag = 1;
        int b = 0;
        int s = 0;
        while(s < t)
        {
            b = s+1;
            for(int i=1 ;i<=n; i++)
            {
                if(op[i].x <= b  && op[i].y >= b)
                {
                    if(s < op[i].y) {s=op[i].y;}
                }
            }
            if(s<b){flag=0;break;}
            else ++sum;
        }
        if(flag==0)printf("-1\n");
        else printf("%d\n",sum);
    }
    return 0;
}
水波。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值