1006 Sign In and Sign Out (25 分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目大意

‎每天开始时,在机房里签到的第一个人会开门,最后一个签出的人会锁门。鉴于登录和注销的记录,您应该找到当天解锁并锁定门的人。‎

‎输入规格:‎

‎每个输入文件包含一个测试用例。每个事例都包含一天的记录。大小写以正整数开头‎M‎,即记录总数,后跟‎M‎行,每行的格式如下:‎

ID_number Sign_in_time Sign_out_time

‎其中 时间以格式给出,并且是不超过15个字符的字符串。‎HH:MM:SSID_number

‎输出规格:‎

‎对于每个测试用例,在一行中输出当天解锁并锁定门的人员的 ID 号。两个 ID 号必须用一个空格分隔。‎

‎注意:可以保证记录是一致的。也就是说,签到时间必须早于每个人的签出时间,并且没有两个人同时登录或注销。‎

‎示例输入:‎

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

‎示例输出:‎

 

SC3021234 CS301133

思路及代码

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <queue>
#include <set>
#include <map>
using namespace std;
int main() 
{
   int m;
   string opentime,closetime;  //记录开门时间,关门时间 
   string opener,closer;    //记录开门者,关门者 
   cin>>m;
   
   
   for(int i=0;i<m;i++)
   {
   	  string s1,s2,s3; 
   	  cin>>s1>>s2>>s3;
   	  if(i==0)   
   	  //把所有事情都先看作是第一个人干的,更新开关门时间,开关门的人
   	  {
   	  	 opentime=s2;
   	  	 closetime=s3;
   	  	 opener=s1;
   	  	 closer=s1;
	  }
	  else
	  {
	  	 if(opentime>s2) //更新开门时间和开门的人
	  	 {
	  	 	opentime=s2; 
	  	 	opener=s1;
		 }
		 if(closetime<s3) //更新关门时间和关门的人
		 {
		 	closetime=s3;
		 	closer=s1;
		 }
	  }
   }
   cout<<opener<<" "<<closer; //输出就行了
    cout<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值