MPLS实验

根据实验要求,先配上IP

然后进行ospf的宣告

[r2]ospf 1 router-id 2.2.2.2
[r2-ospf-1]area 0
[r2-ospf-1-area-0.0.0.0]network 2.2.2.2 0.0.0.0
[r2-ospf-1-area-0.0.0.0]network 23.1.1.1 0.0.0.0
 

[r3]ospf 1 router-id 3.3.3.3
[r3-ospf-1]area 0
[r3-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 23.1.1.2 0.0.0.0
[r3-ospf-1-area-0.0.0.0]network 34.1.1.1 0.0.0.0

[r4]ospf 1 router-id 4.4.4.4
[r4-ospf-1]area 0
[r4-ospf-1-area-0.0.0.0]network 4.4.4.4 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 34.1.1.2 0.0.0.0
[r4-ospf-1-area-0.0.0.0]network 47.1.1.2 0.0.0.0

宣告完成后用r2的环回pingr3的环回 

然后,在公网内启动mpls
[r2]mpls lsr-id 2.2.2.2
[r2]mpls 
[r2-mpls]mpls ldp
[r2-mpls-ldp]int g0/0/2

[r2-GigabitEthernet0/0/2]mpls
[r2-GigabitEthernet0/0/2]mpls ldp

[r3]mpls lsr-id 3.3.3.3
[r3]mpls 
[r3-mpls]mpls ldp
[r3-mpls-ldp]int g0/0/0

[r3-GigabitEthernet0/0/0]mpls
[r3-GigabitEthernet0/0/0]mpls ldp

[r3-GigabitEthernet0/0/1]mpls
[r3-GigabitEthernet0/0/1]mpls ldp

[r4]mpls lsr-id 4.4.4.4
[r4]mpls 
[r4-mpls]mpls ldp
[r4-mpls-ldp]int g0/0/0

[r4-GigabitEthernet0/0/0]mpls
[r4-GigabitEthernet0/0/0]mpls ldp

接下来给R2和R4建立bgp邻居


[r2]bgp 1 
[r2-bgp]router-id 2.2.2.2
[r2-bgp]peer  4.4.4.4 as-number 1
[r2-bgp]peer 4.4.4.4 con    
[r2-bgp]peer 4.4.4.4 connect-interface lo    
[r2-bgp]peer 4.4.4.4 connect-interface LoopBack 0
[r2-bgp]ipv4     
[r2-bgp]ipv4-family unicast 
[r2-bgp-af-ipv4]undo synchronization 
[r2-bgp-af-ipv4]peer 4.4.4.4 enable 
[r2-bgp]ipv4-family vpnv4
[r2-bgp-af-vpnv4]policy vpn-target 
[r2-bgp-af-vpnv4]peer 4.4.4.4 enable 
 

[r4]bgp 1
[r4-bgp]router-id 4.4.4.4
[r4-bgp]peer 2.2.2.2 as-number 1
[r4-bgp]peer 2.2.2.2 connect-interface LoopBack 0
[r4-bgp]ipv4-family unicast 
[r4-bgp-af-ipv4]undo synchronization 
[r4-bgp-af-ipv4]peer 2.2.2.2 enable 
[r4-bgp]ipv4-family vpnv4
[r4-bgp-af-vpnv4]policy vpn-target 
[r4-bgp-af-vpnv4]peer 2.2.2.2 enable 

 然后在R2和R4上建立vpn空间

[r2]ip vpn-instance a1
[r2-vpn-instance-a1]ipv4-family
[r2-vpn-instance-a1-af-ipv4]routing-table
[r2-vpn-instance-a1-af-ipv4]route-distinguisher 2:2
[r2-vpn-instance-a1-af-ipv4]vpn-target 2:2 export-extcommunity 
[r2-vpn-instance-a1-af-ipv4]vpn-target 2:2 import-extcommunity 

[r2]ip vpn-instance b1
[r2-vpn-instance-b1]ipv4-family 
[r2-vpn-instance-b1-af-ipv4]route-distinguisher 1:1
[r2-vpn-instance-b1-af-ipv4]vpn-target 1:1 export-extcommunity 
[r2-vpn-instance-b1-af-ipv4]vpn-target 1:1 import-extcommunity 


[r4]ip vpn-instance a2
[r4-vpn-instance-a2]ipv4-family 
[r4-vpn-instance-a2-af-ipv4]route-distinguisher 2:2

[r4-vpn-instance-a2-af-ipv4]vpn-target 2:2 export-extcommunity
[r4-vpn-instance-a2-af-ipv4]vpn-target 2:2 import-extcommunity 
[r4]ip vpn-instance b2
[r4-vpn-instance-b2]ipv4-family
[r4-vpn-instance-b2-af-ipv4]route-distinguisher 1:1
[r4-vpn-instance-b2-af-ipv4]vpn-target 1:1 export-extcommunity 
[r4-vpn-instance-b2-af-ipv4]vpn-target 1:1 import-extcommunity 

因为R1和R2之间静态传递,R4和R5之间静态传递,R1和R5的环回可以互相访问,R1属于R2的vpn空间b1,R5属于R4的vpn空间b2

R2绑定vpn空间,并将IP地址在vpn空间内添加

[r2-GigabitEthernet0/0/0]ip binding vpn-instance b1
[r2-GigabitEthernet0/0/0]ip add 192.168.2.2 255.255.255.252
 

然后R1上写上去R5网段的静态

[r1]ip route-static 192.168.3.0 255.255.255.0 192.168.2.2
[r1]ip route-static 192.168.4.0 255.255.255.0 192.168.2.2

R2vpn

[r2]ip route-static vpn-instance b1 192.168.1.0 255.255.255.0 192.168.2.1

[r2]bgp 1
[r2-bgp]ipv4-family vpn    
[r2-bgp]ipv4-family vpn-instance b1
[r2-bgp-b1]import-route direct 
[r2-bgp-b1]import-route static 
 

r5静态

[r5]ip route-static 192.168.1.0 255.255.255.0 192.168.3.2
[r5]ip route-static 192.168.2.0 255.255.255.0 192.168.3.2

R4

[r4]bgp 1

[r4-bgp]ipv4-family vpn-instance b2
[r4-bgp-b2]import-route direct 
[r4-bgp-b2]import-route static 

这时候R1和R5就能互相ping通了

R6和R2通过RIP和R2的bgp进行双向重发布

R6

[r6]rip 1
[r6-rip-1]version 2
[r6-rip-1]network 192.168.1.0
[r6-rip-1]network 192.168.3.0

R2
[r2]rip 1 vpn-instance a1
[r2-rip-1]version 2
[r2-rip-1]network 192.168.2.0
[r2-rip-1]import-route bgp 

[r2]bgp 1
[r2-bgp]ipv4-family vpn-instance a1
[r2-bgp-a1]import-route rip 1

R7和R4通过ospf和R4的bgp进行双向重发布

R7的ospf宣告

[r7]ospf 2 router-id 7.7.7.7
[r7-ospf-2]area 0
[r7-ospf-2-area-0.0.0.0]network 192.168.3.5 0.0.0.0
[r7-ospf-2-area-0.0.0.0]network 192.168.4.2 0.0.0.0

R4的ospf宣告和重发布

[r4]ospf 2 vpn-instance a2
[r4-ospf-2]import-route bgp
[r4-ospf-2]area 0.0.0.0
[r4-ospf-2-area-0.0.0.0]network 192.168.3.6 0.0.0.0


[r4]bgp 1
[r4-bgp]ipv4-family vpn-instance a2
[r4-bgp-a2]import-route ospf 2

R6和R7可以ping通,但是R5不行

最后,R7可以通过单独的网线访问公网,在R7上添加R4的缺省就行了

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值