ENSP-VLAN

拓扑图:

要求:全网可达

第一步:VLAN划分

LSW1划分过程:

[Huawei]vlan 2
[Huawei-vlan2]quit
[Huawei]vlan 3
[Huawei-vlan3]quit
[Huawei]vlan 4
[Huawei-vlan4]quit
[Huawei]vlan 5
[Huawei]interface e0/0/2
[Huawei-Ethernet0/0/2]port link-type access
[Huawei-Ethernet0/0/2]port default vlan 2
[Huawei-Ethernet0/0/2]quit
[Huawei]interface e0/0/3
[Huawei-Ethernet0/0/3]port link-type access
[Huawei-Ethernet0/0/3]port default vlan 3
[Huawei]interface e0/0/4
[Huawei-Ethernet0/0/4]port link-type access
[Huawei-Ethernet0/0/4]port default vlan 4   
[Huawei]interface e0/0/5
[Huawei-Ethernet0/0/5]port link-type access           
[Huawei-Ethernet0/0/5]port default vlan 5        
[Huawei]interface e0/0/1
[Huawei-Ethernet0/0/1]port link-type trunk                  
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan all

路由器AR1配置:

[r1]dhcp enable
Info: The operation may take a few seconds. Please wait for a moment.done.
[r1]interface g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dot1q termination vid 2
[r1-GigabitEthernet0/0/0.1]ip address 172.16.1.1 24
[r1]interface g0/0/0.2
[r1-GigabitEthernet0/0/0.2]dot1q termination vid 3
[r1-GigabitEthernet0/0/0.2]ip address 172.16.2.1 24
[r1]interface g0/0/0.3
[r1-GigabitEthernet0/0/0.3]dot1q termination vid 4
[r1-GigabitEthernet0/0/0.3]ip address 172.16.3.1 24
[r1]interface g0/0/0.4
[r1-GigabitEthernet0/0/0.4]dot1q termination vid 5
[r1-GigabitEthernet0/0/0.4]ip address 172.16.4.1 24
[r1]dhcp enable
[r1]ip pool 1
Info: It's successful to create an IP address pool.
[r1-ip-pool-1]network 172.16.1.0 mask 255.255.255.0
[r1-ip-pool-1]gateway-list 172.16.1.1
[r1-ip-pool-1]dns-list 8.8.8.8
[r1-ip-pool-1]quit
[r1]interface g0/0/0.1
[r1-GigabitEthernet0/0/0.1]dhcp select global
[r1-GigabitEthernet0/0/0.1]arp broadcast enable
[r1-GigabitEthernet0/0/0.1]quit
[r1]ip pool 2
Info: It's successful to create an IP address pool.
[r1-ip-pool-2]network 172.16.2.0 mask 255.255.255.0
[r1-ip-pool-2]gateway-list 172.16.2.1
[r1-ip-pool-2]dns-list 8.8.8.8
[r1-ip-pool-2]quit
[r1]interface g0/0/0.2
[r1-GigabitEthernet0/0/0.2]dhcp select global
[r1-GigabitEthernet0/0/0.2]arp broadcast enable
[r1-GigabitEthernet0/0/0.2]quit
[r1]ip pool 3
Info: It's successful to create an IP address pool.
[r1-ip-pool-3]network 172.16.3.0 mask 255.255.255.0
[r1-ip-pool-3]gateway-list 172.16.3.1
[r1-ip-pool-3]dns-list 8.8.8.8
[r1-ip-pool-3]quit
[r1]interface g0/0/0.3
[r1-GigabitEthernet0/0/0.3]dhcp select global
[r1-GigabitEthernet0/0/0.3]arp broadcast enable
[r1-GigabitEthernet0/0/0.3]quit
[r1]ip pool 4
Info: It's successful to create an IP address pool.
[r1-ip-pool-4]network 172.16.4.0 mask 255.255.255.0
[r1-ip-pool-4]gateway-list 172.16.4.1
[r1-ip-pool-4]dns-list 8.8.8.8
[r1-ip-pool-4]quit
[r1]interface g0/0/0.4
[r1-GigabitEthernet0/0/0.4]dhcp select global
[r1-GigabitEthernet0/0/0.4]arp broadcast enable

LSW2划分过程:

LSW2:[Huawei]interface e0/0/2
[Huawei-Ethernet0/0/2]port link-type access
[Huawei-Ethernet0/0/2]port default vlan 2
[Huawei]interface e0/0/3
[Huawei-Ethernet0/0/3]port link-type access
[Huawei-Ethernet0/0/3]port default vlan 3
[Huawei]interface e0/0/1
[Huawei-Ethernet0/0/1]port link-type trunk
[Huawei-Ethernet0/0/1]
[Huawei-Ethernet0/0/1]port trunk allow-pass vlan all

AR3配置:

[Huawei]sysname r3
[r3]interface g0/0/1
[r3-GigabitEthernet0/0/1]ip address 23.1.1.2 24
[r3-GigabitEthernet0/0/1]quit
[r3]dhcp enable
Info: The operation may take a few seconds. Please wait for a moment.done.
[r3]interface g0/0/0.1
[r3-GigabitEthernet0/0/0.1]dot1q termination vid 2
[r3-GigabitEthernet0/0/0.1]ip address 192.168.1.1 24 
[r3-GigabitEthernet0/0/0.1]quit
[r3]interface g0/0/0.2
[r3-GigabitEthernet0/0/0.2]dot1q termination vid 3
[r3-GigabitEthernet0/0/0.2]ip address 192.168.2.1 24
[r3-GigabitEthernet0/0/0.2]quit
[r3]dhcp enable
[r3]ip pool 1
Info: It's successful to create an IP address pool.
[r3-ip-pool-1]network 192.168.1.0 mask 255.255.255.0
[r3-ip-pool-1]gateway-list 192.168.1.1
[r3-ip-pool-1]dns-list 8.8.8.8
[r3-ip-pool-1]quit
[r3]interface g0/0/0.1
[r3-GigabitEthernet0/0/0.1]dhcp select global
[r3-GigabitEthernet0/0/0.1]arp broadcast enable
[r3-GigabitEthernet0/0/0.1]quit
[r3]ip pool 2
Info: It's successful to create an IP address pool.
[r3-ip-pool-2]network 192.168.2.0 mask 255.255.255.0
[r3-ip-pool-2]gateway-list 192.168.2.1
[r3-ip-pool-2]dns-list 8.8.8.8
[r3-ip-pool-2]quit
[r3]interface g0/0/0.2
[r3-GigabitEthernet0/0/0.2]dhcp select global
[r3-GigabitEthernet0/0/0.2]arp broadcast enable
[r3-GigabitEthernet0/0/0.2]quit

第二步:所有路由器检查地址匹配是否完成

第三步:创建环回

[r1]interface LoopBack 0
[r1-LoopBack0]ip address 1.1.1.1 32
[r2]interface LoopBack 0
[r2-LoopBack0]ip address 2.2.2.2 32
[r3]interface LoopBack 0
[r3-LoopBack0]ip address 3.3.3.3 32

第四步:OSPF宣告

[r1]ospf 100
[r1-ospf-100]ospf 100 router-id 1.1.1.1
Info: The configuration succeeded. You need to restart the OSPF process to valid
ate the new router ID.
[r1-ospf-100]area 1
[r1-ospf-100-area-0.0.0.1]network 0.0.0.0 255.255.255.255
[r2-ospf-100]area 0
[r2-ospf-100-area-0.0.0.0]network 23.1.1.1 0.0.0.0
[r2-ospf-100-area-0.0.0.0]network 2.2.2.2 0.0.0.0                     
[r2-ospf-100]ospf 100 router-id 2.2.2.2
Info: The configuration succeeded. You need to restart the OSPF process to valid
ate the new router ID.
[r2-ospf-100]area 1
[r2-ospf-100-area-0.0.0.1]network 12.1.1.2 0.0.0.0
[r3]ospf 100
[r3-ospf-100]ospf 100 router-id 3.3.3.3
Info: The configuration succeeded. You need to restart the OSPF process to valid
ate the new router ID.
[r3-ospf-100]area 0
[r3-ospf-100-area-0.0.0.0]network 23.1.1.2 0.0.0.0
[r3-ospf-100-area-0.0.0.0]quit
[r3-ospf-100]area 2
[r3-ospf-100-area-0.0.0.2]network 0.0.0.0 255.255.255.255
[r3-ospf-100-area-0.0.0.2]quit                   

第五步:测试全网可达

 

 

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值