[UVA10474]大理石在哪儿 Where is the Marble? 题解(STL初步:排序与检索)

大理石在哪儿 Where is the Marble? - 洛谷

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smart kid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

Input

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative. Input is terminated by a test case where N = 0 and Q = 0.

Output

For each test case output the serial number of the case. For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below: • ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered 1, 2, . . . , N. • ‘x not found’, if the marble with number x is not present. Look at the output for sample input for details.

Sample Input

4 1

2 3 5 1

5

5 2

1 3 3 3 1

2 3

0 0

Sample Output

CASE# 1:

5 found at 4

CASE# 2:

2 not found

3 found at 3

题意翻译

现有N个大理石,每个大理石上写了一个非负整数。首先把各数从小到大排序,然后回 答Q个问题。每个问题问是否有一个大理石写着某个整数x,如果是,还要回答哪个大理石上 写着x。排序后的大理石从左到右编号为1~N。

题解

标准答案(STL初步:排序与检索)

#include<cstdio>
#include<algorithm>
using namespace std;

const int N=10005;
int a[N];
int main(){
	int n,q,x,kase=0;
	while(scanf("%d%d",&n,&q)==2&&n){
		printf("CASE# %d:\n",++kase);
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		} 
		sort(a,a+n);
		while(q--){
			scanf("%d",&x);
			int p=lower_bound(a,a+n,x)-a; //lower_bound()利用二分查找的方法在一个排好序的数组中进行查找
			if(a[p]==x){
				printf("%d found at %d\n",x,p+1);
			}else{
				printf("%d not found\n",x);
			}
		}
	}
	
	return 0;
}

注意lower_bound( )和upper_bound( )的用法!!!

lower_bound( )和upper_bound( )都是利用二分查找的方法在一个排好序的数组中进行查找的。//时间复杂度较低

在从小到大的排序数组中,lower_bound( begin,end,num)从数组的begin位置到end-1位置二分查找第一个大于或等于num的数字,找到返回该数字的地址,不存在则返回end。通过返回的地址减去起始地址,得到找到数字在数组中的下标。upper_bound( begin,end,num)从数组的begin位置到end-1位置二分查找第一个大于num的数字,找到返回该数字的地址,不存在则返回end。通过返回的地址减去起始地址,得到找到数字在数组中的下标

其他解法(时间复杂度较高)

#include<cstdio>
#include<algorithm>
using namespace std;

const int N=10005;
int a[N];
int b[N];
int main(){
	int n,q,ant=0;
	while(1){
		ant++;
		scanf("%d%d",&n,&q);
		
		if(n==0||q==0){
			break;
		}
		
		for(int i=0;i<n;i++){
			scanf("%d",&a[i]);
		}
		for(int i=0;i<q;i++){
			scanf("%d",&b[i]);
		}
		sort(a,a+n);
		printf("CASE# %d:\n",ant);
		for(int i=0;i<q;i++){
			for(int j=0;j<n;j++){
				if(b[i]==a[j]){
					printf("%d found at %d\n",b[i],j+1);
					break;
				}
				if(j==n-1){
					printf("%d not found\n",b[i]);
				}
			}
		}              //直接暴力查找
	}
	
	return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

古谷彻

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值