[UVA156]反片语 Ananagrams 题解(映射:map 详解)

反片语 Ananagrams - 洛谷

Most crossword puzzle fans are used to anagrams — groups of words with the same letters in different orders — for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ. Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE. Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus ‘tIeD’ and ‘EdiT’ are anagrams. The file will be terminated by a line consisting of a single ‘#’.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

Sample Input

ladder came tape soon leader acme RIDE lone Dreis peat

ScAlE orb eye Rides dealer NotE derail LaCeS drIed

noel dire Disk mace Rob dries

#

Sample Output

Disk

NotE

derail

drIed

eye

ladder

soon

题意翻译

输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文本的另外一个单词。在判断是否满足条件时,字母不分大小写,但在输出时应保留输入的大小写,按字典序排列(所有大写字母在所有小写字母的前面)。

题解

map简介

map是STL的一个关联容器,它提供一对一的hash

  • 第一个可以称为关键字(key),每个关键字只能在map中出现一次
  • 第二个可以称为该关键字的值(value)

map以模板(泛型)方式实现,可以存储任意类型的数据,包括使用者自定义的数据类型。Map主要用于资料一对一映射(one-to-one)的情況,map內部的实现自建一颗红黑树,这颗树具有对数据自动排序的功能。在map内部所有的数据都是有序的,后边我们会见识到有序的好处。比如一个班级中,每个学生的学号跟他的姓名就存在著一对一映射的关系。

map的功能

自动建立key-value的对应。key和value可以是任意你需要的类型,包括自定义类型。

map的使用

使用map得包含map类所在的头文件#include <map>

map对象是模板类,需要关键字和存储对象两个模板参数:

std:map<int, string> personnel;

这样就定义了一个用int作为索引,并拥有相关联的指向string的指针.

为了使用方便,可以对模板类进行一下类型定义,

typedef map<int,CString> UDT_MAP_INT_CSTRING;

UDT_MAP_INT_CSTRING enumMap;

map的基本操作函数

     begin()         //返回指向map头部的迭代器
     clear()        //删除所有元素
     count()         //返回指定元素出现的次数
     empty()         //如果map为空则返回true
     end()           //返回指向map末尾的迭代器
     equal_range()   //返回特殊条目的迭代器对
     erase()         //删除一个元素
     find()          //查找一个元素
     get_allocator() //返回map的配置器
     insert()        //插入元素
     key_comp()      //返回比较元素key的函数
     lower_bound()   //返回键值>=给定元素的第一个位置
     max_size()      //返回可以容纳的最大元素个数
     rbegin()        //返回一个指向map尾部的逆向迭代器
     rend()          //返回一个指向map头部的逆向迭代器
     size()          //返回map中元素的个数
     swap()          //交换两个map
     upper_bound()   //返回键值>给定元素的第一个位置
     value_comp()    //返回比较元素value的函数

标准答案

#include<iostream>
#include<string>
#include<cctype>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;

map<string,int> cnt;
vector<string> word;

//将单词s进行"标准化" 
string repr(const string& s){
	string ans=s;
	for(int i=0;i<ans.length();i++){
		ans[i]=tolower(ans[i]);			//tolower函数把大写字母转换为小写字母
	}
	sort(ans.begin(),ans.end());		//排序 
	return ans;
}

int main(){
	int n=0;
	string s;
	while(cin>>s){
		if(s[0]=='#'){
			break;
		}
		word.push_back(s);				//将一个新的元素加到vector的最后面
		string r=repr(s);
		if(!cnt.count(r)){				//返回出现的次数
			cnt[r]=0;
		}
		cnt[r]++;
	}
	vector<string> ans;
	for(int i=0;i<word.size();i++){
		if(cnt[repr(word[i])]==1){
			ans.push_back(word[i]);   //若出现过一次,添加入ans后面 
		}
	}
	sort(ans.begin(),ans.end());     //排序 
	for(int i=0;i<ans.size();i++){
		cout<<ans[i]<<"\n";
	}

	return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

古谷彻

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值