Vector的用法1

问题 A: Course List for Student (25)

时间限制: 1 Sec 内存限制: 32 MB
提交: 1226  解决: 331
[提交][状态][讨论版][命题人:外部导入]

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

AC: 

#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
const int maxn=26*26*26*10+10;//设置向量范围 

vector<int> vi[maxn];

int id(string str){
	
	int k=0,i;
	for(i=0;i<str.length()-1;i++){
		k=k*26+(str[i]-'A');
	}
	
	k=k*10+(str[i]-'0');
	
	return k;
}

int main(){
	
	int n,m;
	while(cin>>n>>m){
		
		string stu;
		int item,num;
		for(int i=0;i<m;i++){
			
			cin>>item>>num;
			for(int j=0;j<num;j++){
				cin>>stu;
				
				vi[id(stu)].push_back(item);//该学生学的学科 
			}	
			
		}
		
		for(int i=0;i<n;i++){
			cin>>stu;
			
			vector<int> t=vi[id(stu)];
			cout<<stu<<" "<<t.size()<<" ";			
			
			if(t.size()!=0){
				
				sort(t.begin(),t.end());
				vector<int>::iterator it;
				for(it=t.begin();it!=t.end();it++){
					cout<<*it<<" ";
				}
		
			}
			
			cout<<endl;
		}
		
	} 
	
 
	return 0;
}

 

TLE时间超限代码(思路与上述代码一样,但是好像用map容易超时) 

#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
const int maxn=100010;

int n,m;
map<string,vector<int> > mp; //人名映射到长度可变的数组,便于存放学科 


int main(){
	
	while(cin>>n>>m){
		
		string stu;
		int item,num;
		for(int i=0;i<m;i++){
			
			cin>>item>>num;
			for(int j=0;j<num;j++){
				cin>>stu;
				
				mp[stu].push_back(item);//学生所学学科 
			}
	
		}
		
		
		for(int i=0;i<n;i++){
			cin>>stu;
			cout<<stu<<" "<<mp[stu].size()<<" ";
			
			if(mp[stu].size()!=0){
				
				sort(mp[stu].begin(),mp[stu].end());
				vector<int>::iterator it;
				for(it=mp[stu].begin();it!=mp[stu].end();it++ )
				 cout<<*it<<" ";
			}
			cout<<endl;
		}
	
	}
	
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
嵌套vector主要用于创建二维数组或矩阵的数据结构。引用给出了vector的初始化和嵌套的基础用法。例如,可以使用以下代码创建一个3行4列的矩阵,并初始化每个元素为'\0': vector<vector<char>> matrix(3, vector<char>(4, '\0')); 引用展示了向嵌套的vector中添加元素的方法。例如,可以使用以下代码向一个名为M的嵌套vector中添加两个内层vectorvector<vector<int>> M; vector<int> N1 = {1, 2, 3}; vector<int> N2 = {4, 5, 6}; M.push_back(N1); M.push_back(N2); 引用提供了访问嵌套vector中元素的示例代码。可以使用迭代器来遍历嵌套vector中的元素。以下是一个示例代码,输出嵌套vector的元素: vector<vector<char>> vc(3, vector<char>(4, '\0')); for (auto it = vc.begin(); it != vc.end(); ++it) { for (auto vit = (*it).begin(); vit != (*it).end(); ++vit) { cout << *vit << " "; } cout << endl; } 以上是关于vector嵌套vector的基本用法。可以根据实际需求使用嵌套的vector来存储和操作二维数据。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [vector的嵌套用法](https://blog.csdn.net/qq_43399648/article/details/119207543)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] - *2* [C++ 中vector的嵌套使用](https://blog.csdn.net/qq_35027690/article/details/106604422)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT0_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值