玲珑杯 1056 - A plus B

Two octal number integers a, b are given, and you need calculate the result a - b in octal notation.
If the result is negative, you should use the negative sign instead of complement notation.

INPUT
The first line is an integer T(1 <= T <= 1000), indicating the number of test cases.For each case, the first and only line contains two octal integers a, b.(0 <= a, b < 2^32)
OUTPUT
Print the result, one per line, in octal notation.
SAMPLE INPUT
176 7
SAMPLE OUTPUT

67 

题意:给你俩八进制的数,让你求他俩的差,注意如果a<b的情况,首先你要知道八进制的表示方法诗%o,然后你要知道的是,int 的最大范围是2^31-1,而unsigned int de shi 2^32-1

#include<iostream>

#include<cstdio>
using namespace std;
int main()
{
 int t;
  unsigned int a,b;
  cin>>t;
  while(t--)
  {
    scanf("%o%o",&a,&b);
    if(a<b)
    {
      swap(a,b);
      cout<<"-";
    }
    printf("%o\n",a-b);
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值