hdu 1710 Binary Tree Traversals

Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output

7 4 2 8 9 5 6 3 1

题意:根据前序和中序写出后序  前序:1 2 4 7 3 5 8 9 6 中序:4 7 2 1 8 5 9 3 6 求出后序:7 4 2 8 9 5 6 3 1

首先得知道是如何前序遍历、中序遍历、后序遍历的,自己上网查下,我在这里就不多说了

思路:第一步:根据前序可知根节点为1;第二步:根据中序可知4 7 2为根节点1的左子树和8 5 9 3 6为根节点1的右子树;第三步:递归实现,把4 7 2当做新的一棵树和8 5 9 3 6也当做新的一棵树;第四步:在递归的过程中输出后序。

代码实现:

复制代码
//根据前序和中序遍历写出后序遍历
#include<iostream>
using namespace std;
int t1[1001],t2[1001];
void sousuo(int a,int b,int n,int flag)
{
    
    if(n==1)//如果存在左子树或右子树就直接输出
    {
        printf("%d ",t1[a]);
        return ;
    }
    else if(n<=0)//如果不存在左子树或右子树就返回上一层
        return ;
    int i;//继续罚分为左子树和右子树
    for(i=0;t1[a]!=t2[b+i];i++) ;//找到罚分点也就是根节点
    sousuo(a+1,b,i,0);//左子树的遍历
    sousuo(a+i+1,b+i+1,n-i-1,0);//右子树的遍历
    if(flag==1)//最原始的跟节点
        printf("%d",t1[a]);
    else//一般的根节点
        printf("%d ",t1[a]);
}
int main()
{
    int n,i;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
            scanf("%d",&t1[i]);//t1中存的是前序
        for(i=1;i<=n;i++)//t2中存的中序
            scanf("%d",&t2[i]);
        sousuo(1,1,n,1);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值