Easy Problem VI

Description In this problem you are to calculate the sum of all integers from 1 to n, but you should take all powers of two with minus in the sum. For example, for n=4 the sum is equal to -1-2+3-4=-4, because 1, 2 and 4 are 2^0, 2^1 and 2^2 respectively.
Calculate the answer for t values of n.
Input

The first line of the input contains a single integer t (1≤t≤100) — the number of values of n to be processed.

Each of next t lines contains a single integer n (1≤n≤10^9).
Output

Print the requested sum for each of t integers n given in the input.

Sample Input

2

4 1000000000
Sample Output
-4
499999998352516354
题意:就是求1~n的和 ,只不过其中如果是i是2的幂的话,就是加上它的负数
思路先用数组存一下2的幂,最多粗面30个,因为题上给的数小于2的31次幂 再算n(n+1)/2,把那些是2的幂的数减去两倍
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
  int main(){
  long long a[100];
  int t,k;
  long long n,i;
  long long sum;
  k=0;
  sum=1;
  a[k]=1;
  for(i=1;i<32;i++){
    sum*=2;
    a[++k]=sum;
  }
  scanf("%d",&t);
  while(t--){
    sum=0;
    scanf("%lld",&n);
    sum=n*(n+1)/2;
    for(i=0;i<=k;i++){
        if(a[i]<=n)
            sum-=2*a[i];
    }
    printf("%lld\n",sum);
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值