HDU - 2612 Find a way

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
Sample Output
66
88
66
题意:从Y和M到达同一个@,求到哪个@的时候两个人所走的路最短。.可走 # 不可走。
思路:从|YM 分别广搜一遍用数组记录到每个点的最短路,搜两遍之后,遍历一下地图,找到@点,找到两人到哪个最短
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
char Map[205][205];
int book1[205][205];
int book2[205][205];
int n,m;
struct node {
    int x,y;
    int stemp;
} y,M;

int text(node d) {
    if(d.x<0 || d.x>=n || d.y<0 || d.y>=m)
        return 0;
    if(Map[d.x][d.y]=='#')
        return 0;
    return 1;

}

void BFS1(node u) {
    struct node d;
    queue<node>q;
    int next[4][2]= { {0,1},{1,0},{0,-1},{-1,0} };
    int k;
    while(!q.empty()) q.pop();
    u.stemp=0;
    book1[u.x][u.y]=1;
    q.push(u);
 //   printf("R x=%d y=%d b=%d\n",u.x,u.y,book1[u.x][u.y]);
    while(!q.empty()) {
        u=q.front();
        q.pop();
   //     printf("C x=%d y=%d b=%d\n",u.x,u.y,book1[u.x][u.y]);
        for(k=0; k<4; k++) {
            d.x=u.x+next[k][0];
            d.y=u.y+next[k][1];
    //        printf("tx=%d\n",text(d) );
            if(text(d)==1 && book1[d.x][d.y]==0) {//判断能不能走,和是否走过
                d.stemp=u.stemp+1;
                book1[d.x][d.y]=d.stemp;
                q.push(d);
        //        printf("R x=%d y=%d b=%d\n",d.x,d.y,book1[d.x][d.y]);
            }

        }
    }
}

void BFS2(node u) {
    struct node d;
    queue<node>q;
    int next[4][2]= { {0,1},{1,0},{0,-1},{-1,0} };
    int k;
    while(!q.empty()) q.pop();
    u.stemp=0;
    book2[u.x][u.y]=1;
    q.push(u);
 //    printf("R x=%d y=%d b=%d\n",u.x,u.y,book2[u.x][u.x]);
    while(!q.empty()) {
        u=q.front();
        q.pop();
  //       printf("C x=%d y=%d b=%d\n",u.x,u.y,book2[u.x][u.y]);
        for(k=0; k<4; k++) {
            d.x=u.x+next[k][0];
            d.y=u.y+next[k][1];
            if(text(d)==1 && book2[d.x][d.y]==0) {
                d.stemp=u.stemp+1;
                book2[d.x][d.y]=d.stemp;
                q.push(d);
        //         printf("R x=%d y=%d b=%d\n",d.x,d.y,book2[d.x][d.y]);
            }

        }
    }
}

int main() {
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF) {
        getchar();
        for(i=0; i<n; i++) {
            for(j=0; j<m; j++) {
                scanf("%c",&Map[i][j]);
                if(Map[i][j]=='Y') {
                    y.x=i;
                    y.y=j;
                }
                if(Map[i][j]=='M') {
                    M.x=i;
                    M.y=j;
                }
            }
            getchar();
        }
        memset(book1,0,sizeof(book1));
        memset(book2,0,sizeof(book2));//多次输入
        BFS1(y);
        BFS2(M);//对两个人的进行广搜
        int ans=99999999;
        for(i=0; i<n; i++) {
            for(j=0; j<m; j++) {
                if(Map[i][j]=='@') {
                    if(book1[i][j]!=0 && book2[i][j]!=0) {
                        ans=min(ans,book1[i][j]+book2[i][j]);
                    }
                }
            }
        }
        printf("%d\n",ans*11);
    }


}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值