nyoj 284 坦克大战(广搜+优先队列)

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture).

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
输入
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出
For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
样例输入
3 4
YBEB
EERE
SSTE
0 0
样例输出

8

题意:就是说坦克大战的这个游戏,Y是起点,T是终点,S R 是不能走的点,E是能走的点,B是要先打一下 才能走的点,问你走到重点的最短路是多少,不能就-1.

思路:就是广搜的思路,这里因为相当于走B是要花费2的,所以用例优先队列,先走花费小的点。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<functional>
#include<queue>
using namespace std;
    int m,n,sx,sy,f;
    char Map[305][305];
    int book[305][305];
struct node{
    int x,y;
    int stemp;
    friend bool operator < (node n1,node n2){//优先队列
     return n1.stemp > n2.stemp;
    }
}u,e;
int text(node a){//判断这一个点能不能走
    if(a.x<0 || a.y<0 || a.x>=n || a.y>=m)
         return 0;
    if(Map[a.x][a.y]=='R'|| Map[a.x][a.y]=='S')
        return 0;
    return 1;

}
void BFS(){
    priority_queue<node>q;
    while(!q.empty()) q.pop();
    memset(book,0,sizeof(book));
    int next[4][2]={ {0,1},{1,0},{0,-1},{-1,0} };
    int k;
    u.x=sx;
    u.y=sy;
    u.stemp=0;
    book[sx][sy]=1;//标记走过的点
    q.push(u);
    while(!q.empty()){
        u=q.top();
        q.pop();
       // printf("C x=%d y=%d stemp=%d\n",u.x,u.y,u.stemp);
        if(Map[u.x][u.y]=='T'){
            f=1;
            printf("%d\n",u.stemp);
            break;
        }
        for(k=0;k<4;k++){
            e.x=u.x+next[k][0];
            e.y=u.y+next[k][1];
            e.stemp=u.stemp+1;
            if(text(e)==1 && book[e.x][e.y]==0){
                if(Map[e.x][e.y]=='B')//如果是B的话,就要花费2
                    e.stemp++;
                q.push(e);
            //     printf("R x=%d y=%d stemp=%d\n",e.x,e.y,e.stemp);
                book[e.x][e.y]=1;
            }
        }
    }
    if(f==0)
        printf("-1\n");
}
int main(){
   int i,j;
   while(scanf("%d%d",&n,&m) && m+n){
    getchar();
    for(i=0;i<n;i++){
        for(j=0;j<m;j++){
            scanf("%c",&Map[i][j]);
            if(Map[i][j]=='Y'){
                sx=i;
                sy=j;
            }
        }
        getchar();
    }
    f=0;
    BFS();
   }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值