hdu 1242 Rescue(广搜+优先队列)

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output

13

题意:给你一个M,N的地图,#不能走,.能走,X是走着要多花费一个单位时间,问你r走到a的最短路。

需要注意的是,题上说是许多人来救a,所以要从a搜到最近的r,因为步数不都是1,所以要用优先队列。

#include<iostream>
#include<cstdio>
#include<queue>
#include<functional>
#include<cstring>
using namespace std;
int n,m;
char Map[205][205];
int book[205][205];
int sx,sy,f;
struct node {
    int x;
    int y;
    int stemp;
    friend bool operator <(node n1,node n2) {//优先队列
        return n1.stemp>n2.stemp;//先弹出步数最短的
    }

} u,e;
int text(node a) {
    if(a.x<0 || a.x>=n || a.y<0 || a.y>=m)//超界
        return 0;
    if(Map[a.x][a.y]=='#')//不能走的点
        return 0;
    return 1;
}
void BFS() {
    priority_queue<node>q;
    while(!q.empty()) q.pop();
    int next[4][2]= { {0,1},{1,0},{0,-1},{-1,0} };
    int k;
    u.x=sx;
    u.y=sy;
    u.stemp=0;
    book[u.x][u.y]=1;//标记走过的点
    q.push(u);
    // printf("R x=%d y=%d stemp=%d\n",u.x,u.y,u.stemp);
    while(!q.empty()) {
        u=q.top();
        q.pop();
        //   printf("c x=%d y=%d stemp=%d\n",u.x,u.y,u.stemp);
        if(Map[u.x][u.y]=='r') {
            f=1;
            printf("%d\n",u.stemp);
            break;
        }
        for(k=0; k<4; k++) {
            e.x=u.x+next[k][0];
            e.y=u.y+next[k][1];
            if(text(e)==1 && book[e.x][e.y]==0) {
                if(Map[e.x][e.y]=='x')
                    e.stemp=u.stemp+2;//如果是X,步数为2
                else
                    e.stemp=u.stemp+1;
                q.push(e);
                book[e.x][e.y]=1;
                //        printf("R x=%d y=%d stemp=%d\n",e.x,e.y,e.stemp);
            }
        }
    }
    if(f==0)//搜不到
        printf("Poor ANGEL has to stay in the prison all his life.\n");
}
int main() {
    int i,j;

    while(scanf("%d%d",&n,&m)!=EOF) {
        getchar();
        for(i=0; i<n; i++) {
            for(j=0; j<m; j++) {
                scanf("%c",&Map[i][j]);
                if(Map[i][j]=='a') {
                    sx=i;
                    sy=j;//以a点为起点
                    //  printf("sx=%d sy=%d\n",sx,sy);
                }

            }
            getchar();
        }
        memset(book,0,sizeof(book));
        f=0;
        BFS();
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值