POJ - 1988 Cube Stacking

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0

2

题意:给你1~n个木块初始状态是n堆,每堆一个,t次操作,如果是M的话,就是把a这一堆放到b堆的上面,如果是C的话,就是查询a下面有多少个木块。

思路,并查集,不过要记录某一堆的总木块数量,sum[],方便合并的时候,计算某个木块下面的木块数量,还要记录每个木块下面的数量,数组numunder[]

#include<iostream>
#include<cstdio>
using namespace std;
#define N 30005
int father[N];
int sum[N];
int numunder[N];
void init(){
    int i;
    for(i=0;i<=N;i++){
        father[i]=i;
        sum[i]=1;
        numunder[i]=0;
    }
}
int Find(int x){
    if(x!=father[x]){
        int f=father[x];
        father[x]=Find(father[x]);
        numunder[x]+=numunder[f];//递归去更新每个的下面木块的数量
    }
    return father[x];
}
void Move(int a,int b){
    int f1=Find(a);
    int f2=Find(b);
    father[f1]=f2;//是将其下面的木块当成父亲

    numunder[f1]=sum[f2];//f1堆下面的木块量是f2堆的总量
    sum[f2]+=sum[f1];//合并之后f2堆的总数变化
}
int main(){
    init();//初始化
    int t;
    char ch;
    int a,b;
    scanf("%d",&t);
    while(t--){
        getchar();
        scanf("%c",&ch);
        if(ch=='M'){
            scanf("%d%d",&a,&b);
            Move(a,b);
        }
        else if(ch=='C'){
            scanf("%d",&a);
            Find(a);//找到a的下面的木块
            printf("%d\n",numunder[a]);
        }

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值