L2-012. 关于堆的判断

题目如下


L2-012. 关于堆的判断

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
陈越

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • “x is the root”:x是根结点;
  • “x and y are siblings”:x和y是兄弟结点;
  • “x is the parent of y”:x是y的父结点;
  • “x is a child of y”:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
其实这道题重点就是建树,用前面那个实现堆的结构的建树模板就可以,后面判断时只要根据每个数在数组的下标来计算判断就ok了,
但是需要记录每个节点的下标,刚开始我用的数组来记录,提交只过了一个案例,后来发现节点还可以是负数,这时就不能用数组来记
录,于是换成了map,键为节点数值,值为下标,就可以了。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>

using namespace std;

int n, a[1005];

//建树的 “模板”
void up( int son )
{
    int t = a[son];
    int tson = son;
    while( (tson > 1)&&( a[tson/2] > t))
    {
        a[tson] = a[tson/2];
        tson = tson/2;
    }
    a[tson] = t;
}

void charu( int  t)
{
    a[ ++n ] = t;
    up( n );
}


int main ()
{
    int k, m, x, y;;
    map <int, int> index; //记录下标
    string s;
    cin >> k >> m;
    n=0;
    //建树
    for(int i=0; i<k; i++)
    {
        cin >> x;
        charu(x);
    }
    //给map赋值
    for(int i=1; i<=n; i++)
    {
        index[a[i]] = i;
    }
    for(int i=0; i<m; i++)
    {
        cin >> x;
        cin >> s;
        int index_x = index[x]; 
        int index_y;
        if(s[0] == 'a')
        {
            cin >> y;
            getline(cin, s);  //这个函数可以输入一个带空格的字符串
            index_y = index[y];
            if(index_x/2 == index_y/2)
                puts("T");
            else
                puts("F");
        }
        else
        {
            cin >> s;
            cin >> s;
            if(s[0] == 'r')
            {
                if(index_x == 1)
                    puts("T");
                else
                    puts("F");
            }
            else if(s[0] == 'p')
            {
                cin >> s;
                cin >> y;
                index_y = index[y];
                if(index_y/2 == index_x)
                    puts("T");
                else
                    puts("F");

            }
            else
            {
                cin >> s;
                cin >> y;
                index_y = index[y];
                if(index_x/2 == index_y)
                    puts("T");
                else
                    puts("F");
            }
        }
    }

    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值