Heavy Transportation (最短路)


    Background
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

    Problem
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input
    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output
    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5

Sample Output

    Scenario #1:
    4

题意:要从城市1到城市N运送货物,有M条道路,每条道路都有它的最大载重量,问从城市1到城市N运送最多的重量是多少。其实,就是找一条路径,在不超过每条路径的最大载重量的情况下,使得运送的货物最多。一条路径上的最大载重量为这个路径上权值最小的边。

分析:dijkstra 的变形,我们只需要每次选取离源点载货量最多的那条边,然后通过它去松弛所有路径上的最大载重量;我们知道原始的dijkstra是每次选取离源点最近的边去松弛使得求出的源点到其余点的单源最短路径最短,那么我们这里希望让它路径上权值最小的边尽可能的大,我们就需要去选取离源点权值最大的点,使得它的该路径的最大载重量大一些。

#include<stdio.h>
#define min(a,b) (a<b?a:b)
int e[1010][1010],dis[1010],book[1010];
int m,n;
void Dijkstra()
{
	int i,j,u,min;
	for(i = 0; i <= n; i ++)
	{
		dis[i] = e[1][i];
		book[i] = 0;
	}
	book[1] = 1;
	for(i = 1; i < n; i ++)
	{
		min = -1;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis[j] > min)
			{
				min = dis[j];
				u = j;
			}
		book[u] = 1;
		for(j = 1; j <= n; j ++)
			if(book[j] == 0 && dis[j] < min(dis[u],e[u][j]))
				dis[j] = min(dis[u],e[u][j]);
	}
}
int main()
{
	int i,j,t1,t2,t3,t,count=1;
	scanf("%d",&t);
	while(t --)
	{
		scanf("%d%d",&n,&m);
		for(i = 1; i <= n; i ++)
			for(j = 1; j <= n; j ++)
				e[i][j] = 0;
		for(i = 1; i <= m; i ++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			e[t1][t2] = e[t2][t1] = t3;
		}
		Dijkstra();
		printf("Scenario #%d:\n",count ++);
		printf("%d\n\n",dis[n]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据引用中的背景信息,Hugo Heavy需要一个聪明的人告诉他从他的客户建造的巨型钢铁起重机所在的地方到达需要的地方是否存在一条街道能够承载这个重量。而根据引用中的信息,问题是要找到从交叉点1(Hugo的地方)到交叉点n(客户的地方)的最大运输重量。根据引用中的论文,一个新颖的非线性六自由度运输飞机模型在货物提取中被开发和验证。因此,根据这些信息,问题是要找到从交叉点1到交叉点n的最大允许重量,以便Hugo可以运输给客户。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [Heavy Transportation](https://blog.csdn.net/weixin_43850736/article/details/98874181)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* [Dynamics modeling and control of large transport aircraft in heavy cargo extraction (2011年)](https://download.csdn.net/download/weixin_38653664/19644813)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值