The Suspects (并查集)


    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
    For each case, output the number of suspects in one line.
Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

Sample Output

    4
    1
    1

题意:第一行为两个整数 n 和 m, 其中n是学生的数量, m是团体的数量。每个学生编号是一个0到n-1之间的整数,一开始只有0号学生被视为可能的患者。紧随其后的是团体的成员列表,每组一行。每一行有一个整数k,代表成员数量。之后,有k个整数代表这个群体的学生。一行中的所有整数由至少一个空格隔开。
n = m = 0表示输入结束,不需要处理。
Output
对于每组测试数据, 输出一行可能的患者。

分析:让找出可能的患者,也就是让我们找出和“0”的根节点相同的学生个数。利用并查集不难写出程序。

#include<stdio.h>
int f[30001],m,n;
void init()
{
	int i;
	for(i = 0; i < n; i ++)
		f[i] = i;
	return ;
}
int getf(int v)
{
	if(f[v] == v)
		return v;
	else
	{
		f[v] = getf(f[v]);
		return f[v];
	}
}
void merge(int v, int u)
{
	int t1,t2;
	t1 = getf(v);
	t2 = getf(u);
	if(t1 != t2)
		f[t2] = t1;
	return ;
}
int main()
{
	int i,j,x,y,k,sum;
	while(scanf("%d%d",&n,&m),n != 0 || m != 0)
	{
		sum = 0;
		init();
		for(i = 0; i < m; i ++)
		{
			scanf("%d%d",&k,&x);
			for(j = 0; j < k-1; j ++)
			{
				scanf("%d",&y);
				merge(x,y);
			}
		}
		for(i = 0; i < n; i ++)
			if(getf(i) == f[0])
				sum ++;
		printf("%d\n",sum);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值