FZU NO.2150 Fire Game(枚举+BFS)

题意:

从任意有杂草的两个点(“#”表示杂草)开始,下一单位时间会从当前的着火点向上下左右扩散,求最小时间。

原题描述:

Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

43 3.#.###.#.3 3.#.#.#.#.3 3...#.#...3 3###..##.#

Sample Output

Case 1: 1Case 2: -1Case 3: 0Case 4: 2

代码:

#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#define X first
#define Y second
#define LL long long
#define INF 0x3f3f3f3f
using namespace std;

const int MAX = 12;
bool vis[12][12];//标记数组
int n, m;
int dx[] = {1, 0, -1, 0}, dy[] = {0, 1, 0, -1};//移动坐标
char arr[12][12];//储存地图
struct node{
    int x, y, t;
} grass[105];//储存草的坐标信息以及从上一步到这一步所需要的时间
queue<node> q;
int res, ans;//分别表示从当前两个草出发所需要的时间,草的总个数

int bfs(node a, node b){
    res = 0;
    int temp = 2;
    q.push(a);
    q.push(b);
    vis[a.x][a.y] = vis[b.x][b.y] = true;
    while(!q.empty()){
        node mov = q.front();
        q.pop();
        for(int i = 0; i < 4; i++){
            node p = mov;
            p.x += dx[i], p.y += dy[i], p.t++;
            if(p.x >= 0 && p.x < n && p.y < m && p.y >= 0 && !vis[p.x][p.y] && arr[p.x][p.y] == '#'){
                temp++;
                vis[p.x][p.y] = true;
                res = max(p.t, res);
                q.push(p);
            }
        }
    }
    if(temp < ans)//表示草不能全部被烧完
        res = INF;
    return res;
}

int main(){
    int t;
    scanf("%d", &t);
    int cnt = 0;
    while(t--){
        memset(vis, false, sizeof(vis));
//        memset(d, 0, sizeof(d));
        scanf("%d%d", &n, &m);
        ans = 0;
        for(int i = 0; i < n; i++){
            scanf("%s", &arr[i]);
            for(int j = 0; j < m; j++){
                if(arr[i][j] == '#'){
                    grass[ans++] = (node){i, j, 0};
                }
            }
        }
//        cout << "ans is " << ans << endl;
        if(ans <= 2){
            printf("Case %d: 0\n", ++cnt);
            continue;
        }
        int step = INF;
        for(int i = 0; i < ans; i++){
            for(int j = i + 1; j < ans; j++){
                memset(vis, false, sizeof(vis));
                bfs(grass[i], grass[j]);
                step = min(res, step);
//                cout << "step is " << step<<endl;
            }
        }
        if(step == INF) step = -1;
        printf("Case %d: %d\n", ++cnt, step);
    }
    return 0;
}







  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值