POJ NO.1041 John's trip(字典序输出欧拉回路)

题意:

John买了新车,想开车去拜访他的朋友,已知每条街道上都恰巧有他的一个朋友,所以他想穿过每条街道一次并且回到起点。城镇上街道总数不超过1995,节点总数不超过44,任意一个节点所关联的街道总数不超过44,每一条街道所关联的两个节点都不同,每条街道的编号也不同。起点是第一次输入的两个节点中较小的那个。若存在多条回路,输出字典序最小的。

思路:

输入比较奇葩,题目中要求多种存在多种回路时输出字典序最小的那个,我们便可以先将图存储按照街道编号进行排序再进行后续操作!

原题描述:

Description

Little Johnny has got a new car. He decided to drive around the town to visit his friends. Johnny wanted to visit all his friends, but there was many of them. In each street he had one friend. He started thinking how to make his trip as short as possible. Very soon he realized that the best way to do it was to travel through each street of town only once. Naturally, he wanted to finish his trip at the same place he started, at his parents' house. 

The streets in Johnny's town were named by integer numbers from 1 to n, n < 1995. The junctions were independently named by integer numbers from 1 to m, m <= 44. No junction connects more than 44 streets. All junctions in the town had different numbers. Each street was connecting exactly two junctions. No two streets in the town had the same number. He immediately started to plan his round trip. If there was more than one such round trip, he would have chosen the one which, when written down as a sequence of street numbers is lexicographically the smallest. But Johnny was not able to find even one such round trip. 

Help Johnny and write a program which finds the desired shortest round trip. If the round trip does not exist the program should write a message. Assume that Johnny lives at the junction ending the street appears first in the input with smaller number. All streets in the town are two way. There exists a way from each street to another street in the town. The streets in the town are very narrow and there is no possibility to turn back the car once he is in the street 

Input

Input file consists of several blocks. Each block describes one town. Each line in the block contains three integers x; y; z, where x > 0 and y > 0 are the numbers of junctions which are connected by the street number z. The end of the block is marked by the line containing x = y = 0. At the end of the input file there is an empty block, x = y = 0.

Output

Output one line of each block contains the sequence of street numbers (single members of the sequence are separated by space) describing Johnny's round trip. If the round trip cannot be found the corresponding output block contains the message "Round trip does not exist."

Sample Input

1 2 1
2 3 2
3 1 6
1 2 5
2 3 3
3 1 4
0 0
1 2 1
2 3 2
1 3 3
2 4 4
0 0
0 0

Sample Output

1 2 3 5 4 6 
Round trip does not exist.

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<set>

using namespace std;

#define X first
#define Y second

const int INF = 0x3f3f3f3f;
const int MAX = 2000;
int head[MAX], top, cnt, iq;
int degree[MAX], ans[MAX];
bool vis[MAX];

struct node{
    int to, w, next;
}edge[MAX];

struct node2{
    int u, v, w;
}arr[MAX];

void add_edge(int u, int v, int w)
{
    edge[top].to = v;
    edge[top].w = w;
    edge[top].next = head[u];
    head[u] = top++;
}

void init(){
    top = cnt = iq = 0;
    memset(vis, 0, sizeof(vis));
    memset(head, -1, sizeof(head));
    memset(degree, 0, sizeof(degree));
    memset(ans, 0 ,sizeof(ans));
    memset(arr, 0, sizeof(arr));
}

void dfs(int now){
    for(int k = head[now]; k != -1; k = edge[k].next){
        if(!vis[edge[k].w]){
            vis[edge[k].w] = true;
            dfs(edge[k].to);
            ans[iq++] = edge[k].w;
        }
    }
}

bool check(){
    for(int i = 1; i <= 50; i++)
        if(degree[i] % 2)
            return false;
    return true;
}

bool cmp(node2 a, node2 b){
    return a.w < b.w;
}

int main(){
    int x, y, z;
    while(scanf("%d%d", &x, &y) && (x + y)){
        init();
        scanf("%d", &z);
        arr[cnt].u = x;
        arr[cnt].v = y;
        arr[cnt].w = z;
        cnt++;
        int beg = min(x, y);
        while(scanf("%d%d", &x, &y) && (x + y)){
            scanf("%d", &z);
            arr[cnt].u = x;
            arr[cnt].v = y;
            arr[cnt].w = z;
            cnt++;
        }
        sort(arr, arr + cnt, cmp);
        for(int i = 0; i < cnt; i++){
            add_edge(arr[i].u, arr[i].v, arr[i].w);
            add_edge(arr[i].v, arr[i].u, arr[i].w);
            degree[arr[i].u]++;
            degree[arr[i].v]++;
        }
        if(!check()){
            printf("Round trip does not exist.\n");
            continue;
        }
        dfs(beg);
        for(int i = 0; i < iq; i++){
            printf("%d ", ans[i]);
        }
        printf("\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值