A problem is easy

A problem is easy

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
输入
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10^11).
输出
For each case, output the number of ways in one line
样例输入
2
1
3
样例输出
0

1

 代码实现:

#include<stdio.h>
int main()
{
int n;
scanf("%d",&n);
while(n--)
{
int a,num=0;
scanf("%d",&a);
for(int i=1;(i+1)*(i+1)<=(a+1);i++)
{
if((a+1)%(i+1)==0)
num++;
}
printf("%d\n",num);
}
return 0;
}


知识点:本题语法非常简单,但是需要做额外的数学转化(将公式变形),通过减少循环的使用使得运行时间变短。考察的是思考问题和解决问题的能力。 开始时,我使用的是双重for循环,都超时了,但是看了讨论区才明白做题时不仅仅要实现算法,而且要巧妙地完成,争取时间和空间都占用的最少。


本题解决办法:双重循环肯定超时的 直接用一个判断条件能减少时间   i*j+i+j =N 经过观察,可以变形为i*j+i+j+1=N+1,也就是说,可以进一步变形为(i+1)*(j+1)=N+1,所以i从2判断到sqrt(n+1)即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值