HDU 4310 Hero(贪心)

 Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1263    Accepted Submission(s): 634


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

 

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

 

Output
Output one line for each test, indicates the minimum HP loss.
 

 

Sample Input
1
10 2
2
100 1
1 100
 

 

Sample Output
20

201

题意:Dota游戏中有n组敌人,每次攻击一个敌人会使这个敌人的HP减1,
但是同时你的英雄的DPS(开始是是无穷的)的值会减少,减少值为所有在当前回合仍存活的敌人的DPS总和,若敌人的HP<=0会在这一回合结束后死亡。要求将所有的敌人都消灭后你的英雄的DPS剩余的最多,即求耗费的DPS的值最少。

分析:用贪心解决。血量少攻击高的要先消灭,所以以HP/DPS作为参数排序,即将所有的敌人根据DPS/HP从大到小排序,如果相等,则按HP从小到大排序。


#include<bits/stdc++.h>
using namespace std;
struct di{
	int hp;
	int at;
};
double cmp(di a,di b)
{
	return 1.0*a.at/a.hp>1.0*b.at/b.hp;
}
int sum(di a[],int n)
{
	int all=0;
	for(int i=0;i<n;i++)
	all+=a[i].at;
	return all;
	
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF){
		di a[25] ;
		int i,j,k;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].hp,&a[i].at);
		}
		sort(a,a+n,cmp);
	/*	for(i=0;i<n;i++)
		{
			printf("%d %d\n",a[i].at,a[i].hp);
		}*/
		int min=0;
		int cnt=0;
		while(1)
		{
		
		
			min+=sum(a,n);
			a[cnt].hp--;
			if(a[n-1].hp<=0)break;
			if(a[cnt].hp<=0)
			{
				a[cnt].at=0;
				cnt++;
			}
			
		}
		printf("%d\n",min);
	}
}
一开始直接按攻击力排序了……注意排序的时候double类型
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值