hdoj5489Removed Interval【lis】

Removed Interval

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1282    Accepted Submission(s): 437


Problem Description
Given a sequence of numbers  A=a1,a2,,aN , a subsequence  b1,b2,,bk  of  A  is referred as increasing if  b1<b2<<bk . LY has just learned how to find the longest increasing subsequence (LIS).
Now that he has to select  L  consecutive numbers and remove them from  A  for some mysterious reasons. He can choose arbitrary starting position of the selected interval so that the length of the LIS of the remaining numbers is maximized. Can you help him with this problem?
 

Input
The first line of input contains a number  T  indicating the number of test cases ( T100 ).
For each test case, the first line consists of two numbers  N  and  L  as described above ( 1N100000,0LN ). The second line consists of  N  integers indicating the sequence. The absolute value of the numbers is no greater than  109 .
The sum of N over all test cases will not exceed 500000.
 

Output
For each test case, output a single line consisting of “Case #X: Y”.  X  is the test case number starting from 1.  Y  is the maximum length of LIS after removing the interval.
 

Sample Input
  
  
2 5 2 1 2 3 4 5 5 3 5 4 3 2 1
 

Sample Output
  
  
Case #1: 3 Case #2: 1
 

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<vector>
using namespace std;
const int maxn=100010;
int dp[maxn];
int li[maxn],ri[maxn],num[maxn];
/**********
定义li[i]为在前i位删除[x-l-1,x-1]的lis
ri[i]为从i到n的lis 
***********/
int BS(int n,int k){
	int l=0,r=n-1;
	while(l<=r){
		int mid=(l+r)>>1;
		if(dp[mid]>=k){
			r=mid-1;
		}
		else {
			l=mid+1;
		}
	}
	return l;
}
int main()
{
	int t,i,j,k=1,l,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&l);
		for(i=0;i<n;++i){
			scanf("%d",&num[i]);
		}
		int len=0,ans=0,pos;
		for(i=n-1;i>=0;--i){
			pos=BS(len,-num[i]);
			dp[pos]=-num[i];
			ri[i]=pos;
			if(pos==len)len++;
		}
		len=ans=0;
		memset(li,0,sizeof(li));
		for(i=0;i<n;++i){
			if(i+l<n){
				pos=BS(len,num[i+l]);
				li[i+l]=pos;
			}
			pos=BS(len,num[i]);
			dp[pos]=num[i];
			if(pos==len)len++;
			if(i<n-l)ans=max(ans,pos+1);
		}
		for(i=l;i<n;++i){
			ans=max(ans,ri[i]+li[i]+1);
		}
		printf("Case #%d: %d\n",k++,ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值