hdoj5773The All-purpose Zero【LIS】

The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1440    Accepted Submission(s): 686


Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
 

Author
FZU
 

Source
 

0可以转化成任意整数,包括负数,显然求LIS时尽量把0都放进去必定是正确的。因此我们可以把0拿出来,对剩下的做O(nlogn)的LIS,统计结果的时候再算上0的数量。为了保证严格递增,我们可以将每个权值S[i]减去i前面0的个数,再做LIS,就能保证结果是严格递增的。

/* ***********************************************
Author       : ryc
Created Time : 2016-08-03 Wednesday
File Name    : E:\acmcode\hdoj\5773.cpp
LANGUAGE     : c++
Copyright 2016 ryc All Rights Reserved
************************************************ */
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<list>
#include<map>
using namespace std;
const int maxn=1000010;
int num[maxn];
int s[maxn];
int LIS(int n){
    if(n==0)return 0;
    num[1]=s[1];int len=1;
    for(int i=2;i<=n;++i){
        if(s[i]>num[len]){
            num[++len]=s[i];
            continue;
        }
        int left=1,right=len;
        while(left<=right){
            int mid=(left+right)>>1;
            if(s[i]>num[mid]){
                left=mid+1;
            }
            else {
                right=mid-1;
            }
        }
        num[left]=s[i];
    }
    return len;
}
int main()
{
    int t,T=1,n;cin>>t;
    while(t--){
        scanf("%d",&n);
        int ans=0,cnt=0;
        for(int i=1;i<=n;++i){
            scanf("%d",&num[i]);
            if(num[i]==0)ans++;
            else {
                s[++cnt]=num[i]-ans;
            }
        }
        ans+=LIS(cnt);
        printf("Case #%d: %d\n",T++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值