【PAT】1096. Consecutive Factors (20)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3

5*6*7

分析:这道题目写的比较难懂。

题意是:在一个数的因子中,找出一些因子,这些因子是连续的并且相乘起来可以等于这个数的。

#include<iostream>
#include<cmath>
#include<vector>
using namespace std;

int main(){
	int N, i, maxCnt;
	cin>>N;
	maxCnt = 0;
	vector<int> final;
	for(i=2; i<=sqrt(N); i++){
		int index = i;
		int cnt = 0;
		int tmp = N;
		vector<int> vec;
		vec.clear();	
		while((tmp%index) == 0){
			//可以整除
			vec.push_back(index);
			cnt++;
			tmp /= index;
			index++; 
		}
		
		if(cnt > maxCnt){
			maxCnt = cnt;
			final.clear();
			final.assign(vec.begin(), vec.end());
		}
		
	}
	if(maxCnt == 0){//只能被1和自己本身整除
		cout<<"1"<<endl;
		cout<<N;
		return 0;
	} 

	cout<<maxCnt<<endl;
	if(final.size() != 0)
		cout<<final[0];
		
	for(i=1; i<final.size(); i++){
		cout<<"*"<<final[i];
	}
	cout<<endl;
	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值