The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n1^P + ... nK^P
where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL
If there is no solution, simple output "Impossible".
Sample Input 1:169 5 2Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2Sample Input 2:
169 167 3Sample Output 2:
Impossible
分析:DFS + 剪枝。 http://blog.csdn.net/xyt8023y/article/details/48465993
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
int N, K, P;
vector<int> finalFactor;
long sum = 0;
bool dfs(int n, int cur, vector<int> &factor ){
if(cur == K){
//因子的个数达到了k个
if(n == 0){
//式子的和刚好与N相等
int tmpSum = 0;
for(int i=0; i<factor.size(); i++){
tmpSum += factor[i];
}
if(tmpSum >= sum){
finalFactor = factor;
sum = tmpSum;
}
return true;
}else{
return false;
}
}
int higher = sqrt(n);
int lower = cur>0? factor[cur-1]:1;
for(int i=lower; i<=higher; i++){
long tmp = pow(i,P);
if(tmp > n){
return false;
}else{
factor[cur] = i;
dfs(n-tmp, cur+1, factor);
}
}
return true;
}
int main(int argc, char** argv) {
scanf("%d%d%d",&N,&K,&P);
vector<int> factor(K);
dfs(N,0,factor);
if(finalFactor.size() == 0){
printf("Impossible\n");
return 0;
}
printf("%d = ",N);
for(int i=finalFactor.size()-1; i>=0; i--){
if(i!=0)
printf("%d^%d + ",finalFactor[i],P);
else
printf("%d^%d\n",finalFactor[i],P);
}
return 0;
}