Goldbach's Conjecture

O - Goldbach's Conjecture
Crawling in process... Crawling failed Time Limit:1000MS    Memory Limit:65536KB     64bit IO Format:%I64d & %I64u       

Description

For any even number n greater than or equal to 4, there exists at least one pair of prime numbersp1 and p2 such that

n = p1 +p2

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1,p2) and (p2,p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0

Sample Output

1
2
此题的解题思路:先建立一张素数表,我也是第一次接触,如果直接暴力,应该会超时的;
 
 
 
 
 
#include<iostream>
#include<cstring>
using namespace std;
int f[33000],prime[10000];
int count = 0;

void Select()//建立素数表
{
	for(int i=2;i<=32768;i++)
	{
		if(!f[i])
		{
			prime[count++]=i;
		}
		for(int j=i*i;j<=32768;j+=i)
		{
			f[j]=1;
		}
	}
}
int main()
{
	Select();
	int n,ans;
	while(cin>>n&&n)
	{
		ans=0;
	//	memset(f,0,sizeof(f));

		for(int i=0; 2*prime[i]<=n; i++)
			if(!f[n-prime[i]])
			{
				ans++;
			}
		cout<<ans<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值