链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1822
题目:
Piotr's Ants
Time Limit: 2 seconds
"One thing is for certain: there is no stopping them; the ants will soon be here. And I, for one, welcome our new insect overlords." |
Kent Brockman
Piotr likes playing with ants. He has n of them on a horizontal pole L cm long. Each ant is facing either left or right and walks at a constant speed of 1 cm/s. When two ants bump into each other, they both turn around (instantaneously) and start walking in opposite directions. Piotr knows where each of the ants starts and which direction it is facing and wants to calculate where the ants will end up T seconds from now.
Input
The first line of input gives the number of cases, N. N test cases follow. Each one starts with a line containing 3 integers: L , T and n
(0 <=
n
<= 10000)
. The next n lines give the locations of the n ants (measured in cm from the left end of the pole) and the direction they are facing (L or R).
Output
For each test case, output one line containing "Case #x:" followed by n lines describing the locations and directions of the n ants in the same format and order as in the input. If two or more ants are at the same location, print "Turning" instead of "L" or "R" for their direction. If an ant falls off the pole before Tseconds, print "Fell off" for that ant. Print an empty line after each test case.
Sample Input | Sample Output |
2 10 1 4 1 R 5 R 3 L 10 R 10 2 3 4 R 5 L 8 R | Case #1: 2 Turning 6 R 2 Turning Fell off Case #2: 3 L 6 R 10 R |
Problemsetter: Igor Naverniouk
Alternate solutions: Frank Pok Man Chu and Yury Kholondyrev
解题思路:
掉头等于对穿而过,这点真的用的太美妙了,还有就是这秒(1,R),两秒后一定有蚂蚁在(3,R)的位置
代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 10000+5
struct Arr
{
int id; //输入顺序
int p; //位置
int d; //方向
};
Arr before[maxn],after[maxn];
int cmp(const Arr &a,const Arr &b)
{
return a.p<b.p;
}
int main()
{
int N;
int len,time,n;
scanf("%d",&N);
char dirName[][10]={"L","Turning","R"};
//for(int i = 0;i<3;i++)
// printf("%s ",dirName[i]);
for(int k=0;k<N;k++)
{
char ch;
int p , d;
int order[maxn];
scanf("%d%d%d",&len,&time,&n);
for(int i=0;i<n;i++)
{
scanf("%d %c",&p,&ch);
d=(ch=='L'?-1:1);
before[i]=(Arr){i,p,d};
after[i] = (Arr){0,p+d*time,d};
}
sort(before,before+n,cmp);
for(int i = 0 ; i < n; i++)
order[before[i].id] = i;
sort(after,after+n,cmp);
for(int i = 0; i < n-1; i++)
if(after[i].p == after[i+1].p)
after[i].d = after[i+1].d=0;
printf("Case #%d:\n",k+1);
for(int i = 0; i < n;i++ )
{
int a = order[i];
if(after[a].p<0||after[a].p>len)
printf("Fell off\n");
else
printf("%d %s\n",after[a].p,dirName[after[a].d+1]);
}
printf("\n");
}
return 0;
}