hdu 3371 Connect the Cities,(kruskal算法)

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6326    Accepted Submission(s): 1826


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
 

Author
dandelion
 

Source
 

Recommend
lcy

解题报告:刚开始写的时候,感觉15分钟之内绝对可以完成,但是敲代码的时候明显的有些力不从心,两个村庄很容易合并,三个也容易合并,两个,三个都有该怎么合并呢?

后来搞了个数组来存放,可能有其他方法,但是没有想到,本题的时间700多毫秒

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,k,set[505];

struct node
{
	int u,v,w;
}edge[25005];

int cmp(const node &a,const node &b)
{return a.w<b.w;}

int find(int x)
{
	while(set[x]!=x)
		x=set[x];
	return x;
}

void kruskal()
{
	int ans=0;
	for(int i=1;i<=m;i++)
	{
		int x=find(edge[i].u);
		int y=find(edge[i].v);
		if(x!=y)
		{
			set[x]=y;
			ans+=edge[i].w;
		} 
	}
	int cnt=0;
	for(int i=1;i<=n;i++)
	{
		if(i==find(set[i]))
			cnt++;
	}
	if(cnt>1) printf("-1\n");
	else
		printf("%d\n",ans);
}

int main()
{
	int ncase;
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%d%d%d",&n,&m,&k);
		for(int i=1;i<=m;i++)
			scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
		for(int i=0;i<=n;i++)
			set[i]=i;
		sort(edge+1,edge+m+1,cmp);
		int a1,b1,c1,a[105],b[105],c[105];
		for(int i=1;i<=k;i++)
		{
			scanf("%d",&a1);
			if(a1>1)
			{
				scanf("%d",&a[1]);
				int x=find(a[1]);
				for(int j=1+1;j<=a1;j++)
				{
					scanf("%d",&a[j]);
					int y=find(a[j]);
					set[y]=x;
				}
			}
		} 
		kruskal();
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值