ACM Stall Reservations(挑战程序设计竞赛)

Stall Reservations

Time Limit: 1000ms
Memory Limit: 65536KB
This problem will be judged on  PKU. Original ID:  3190
64-bit integer IO format:  %lld      Java class name:  Main
Special Judge
Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B.  Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Source

#include <iostream>
#include <queue>
#include <algorithm>
#include <cstdio>

using namespace std;

#define MAX_N 50000
#define INF 99999999

int n;
int barnID[MAX_N];

struct Cow
{
    int s,t;
    int ID;
} cow[MAX_N];

bool cmp(const Cow &a,const Cow &b)
{
    if(a.s!=b.s)
        return a.s<b.s;
    return a.t<b.t;
}

struct Stall
{
    int ID;
    int t;
};

bool operator < (const Stall &a,const Stall &b)
{
    return a.t>b.t;
}

priority_queue<Stall> ss;

int main()
{
    scanf("%d",&n);

    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&cow[i].s,&cow[i].t);
        cow[i].ID=i;
    }

    sort(cow,cow+n,cmp);

    int cnt=1;
    ss.push(Stall{cnt,cow[0].t});
    barnID[cow[0].ID]=1;
    for(int i=1;i<n;i++)
    {
        Stall nd=ss.top();

        if(nd.t<cow[i].s)
        {
            ss.pop();
            ss.push(Stall{nd.ID,cow[i].t});
            barnID[cow[i].ID]=nd.ID;
        }
        else
        {
            cnt++;
            barnID[cow[i].ID]=cnt;
            ss.push(Stall{cnt,cow[i].t});
        }
    }

    printf("%d\n",cnt);
    for(int i=0;i<n;i++) printf("%d\n",barnID[i]);

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值