POJ3190-Stall Reservations(区间贪心+优先队列)

Stall Reservations

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13353 Accepted: 4685 Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:

  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time

Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 
 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..

Other outputs using the same number of stalls are possible.

Source

USACO 2006 February Silver

分析:

用优先队列,如果说这个时候能够空出畜栏,就继承之前这个畜栏的编号,

如果说不能空出畜栏就增加畜栏的数目,畜栏的编号是i

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;
struct Cow
{
    int a,b;
    int No;
    bool operator <(const Cow &c) const
    {
        return a<c.a;
    }
} cows[50100];
int pos[50100];
struct stall
{
    int end;
    int No;
    bool operator <(const stall &s) const
    {
        return end>s.end;
    }
    stall (int e,int n):end(e),No(n){ }
    };
int main()
{
    int n;
    scanf("%d",&n);
    for(int  i = 0 ;i<n;i++)
    {
        scanf("%d%d",&cows[i].a,&cows[i].b);
        cows[i].No = i;
    }
    sort(cows,cows+n);
    int total = 0;
    priority_queue<stall> pq;
    for(int  i =0;i<n;i++)
    {

        if(pq.empty())
        {
            ++total;
            pq.push(stall(cows[i].b,total));
            pos[cows[i].No] = total;
        }
        else
        {
            stall st = pq.top();
            if(st.end<cows[i].a)
            {
                //端点也不能重合
                pq.pop();
                pos[cows[i].No] = st.No;
                pq.push(stall(cows[i].b,st.No));
            }
            else
            {
                //对应没有空余的畜栏
                ++total;//畜栏增加
                pq.push(stall(cows[i].b,total));
                pos[cows[i].No] = total;
            }
        }
    }
    printf("%d\n",total);
    for(int i = 0 ;i < n; i++)
        printf("%d\n",pos[i]);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值