问题 D: Sorting It All Out
时间限制: 1 Sec 内存限制: 128 MB
提交: 17 解决: 9
[提交] [状态] [命题人:admin]
题目描述
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
输入
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
输出
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
样例输入
复制样例数据
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
样例输出
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
是一个赤裸裸的拓扑排序
然后就把拓扑排序敲错了...
记得每次清零,还有数据要读完
代码:
#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxx = 30;
int mapp[maxx][maxx];
int inde[maxx];
int n, m, tot;
int ans[maxx];
int in[maxx];
int toposort() {
tot = 0;
int ret = 1, f = 1;
for (int i = 0; i < maxx; i++)
in[i] = inde[i];
for (int k = 0; k < n; k++) {
int q = 0;
f = 0;
for (int i = 0; i < n; i++) {
if (in[i] == 0) {
q++;
}
}
if (q > 1) ret = 0; //表示拓扑关系不明确,无法判断
for (int j = 0; j < n; j++) {
if (in[j] == 0) {
ans[tot++] = j;
in[j]--;
for (int o = 0; o < n; o++) {
if (mapp[j][o])
in[o]--;
}
f = 1;
break;
}
}
if (!f) break;
}
if (!f) return -1; //发生冲突,不能形成拓扑关系
return ret;
}
int main() {
while (~scanf("%d%d", &n, &m)) {
if (n == 0 && m == 0) break;
memset(mapp, 0, sizeof(mapp));
memset(inde, 0, sizeof(inde));
char a, b;
int flag = 0, cnt = 0;
char s[10];
for (int i = 1; i <= m; i++) {
scanf("%s", s);
if (flag) continue;
cnt++;
a = s[0] - 'A';
b = s[2] - 'A';
if (mapp[b][a]) flag = -1;
if (mapp[a][b] == 0) {
mapp[a][b] = 1;
inde[b]++;
}
flag = toposort();
}
if (flag == 1) {
printf("Sorted sequence determined after %d relations: ", cnt);
for (int i = 0; i < tot; i++)
printf("%c", ans[i] + 'A');
puts(".");
} else if (flag == -1)
printf("Inconsistency found after %d relations.\n", cnt);
else if (!flag) puts("Sorted sequence cannot be determined.");
}
return 0;
}