【POJ 1463】【hdu 1054】Strategic game(树形dp)

43 篇文章 0 订阅
33 篇文章 0 订阅
Strategic game
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 7983 Accepted: 3715

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 

  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

[题意][每个节点都可以放一个士兵,这个士兵可以瞭望到与当前节点相连的所有边,求最少需要放多少士兵使得每条边都可被瞭望]
【题解】【树形dp】
【f[i][0/1],用f[i][0]表示当前点不放士兵,以当前点为根的子树需要多少个士兵;f[i][1]表示当前点放士兵,以当前点为根的子树需要多少个士兵。】
【方程:f[i][1]+=f[j][0](j是i的儿子),f[i][0]=min(f[i][1],∑f[j][1]】
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,f[1510][2];
int a[3010],nxt[3010],p[1510],tot;
bool b[1510];
inline void add(int x,int y)
{
	tot++; a[tot]=y; nxt[tot]=p[x]; p[x]=tot;
	tot++; a[tot]=x; nxt[tot]=p[y]; p[y]=tot;
}
void dp(int x,int fa)
{
	int minn=0x7fffffff,num=0;
	int t=0; f[x][1]=1;
    if(a[p[x]]==fa&&nxt[p[x]]==-1) return;
	for(int i=p[x];i!=-1;i=nxt[i])
	 if(a[i]!=fa)
	  {
	  	dp(a[i],x);
	  	f[x][1]+=f[a[i]][0];
	  	f[x][0]+=f[a[i]][1];
	  }
	if(f[x][1]<f[x][0]) f[x][0]=f[x][1];
	return;
}
int main()
{
  while(scanf("%d",&n)==1)
   {
   	tot=0;
   	memset(b,0,sizeof(b));
    memset(f,0,sizeof(f));
    memset(p,-1,sizeof(p));
    memset(nxt,-1,sizeof(nxt));
    for(int i=1;i<=n;++i)
     {
    	int x,m;
        scanf("%d:(%d)",&x,&m);
        for(int j=1;j<=m;++j)
         {
     	    int y;
     	    scanf("%d",&y);
     	    add(x,y); b[y]=1;
	    }
	}
   int root;
   for(int i=0;i<n;++i)
     if(!b[i]) {root=i; break; }
   dp(root,root);
   printf("%d\n",f[root][0]);
   }
  return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值