hdu1054

hdu树形DP

Strategic Game

Problem Description
Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:

the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:

Sample Input
4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output
1
2
题解:
最少点覆盖问题
树形DP解决
对于任意一个节点i来说,可以放士兵和不放士兵两种可能,dp[i][0]表示i点不放士兵,
dp[i][1]表示i放士兵。
状态转移方程:dp[i][1]=sum(min(dp[k][0],dp[k][1])) 由于本节点放士兵,
所以把k节点放士兵和不放士兵的较小值加起来,k为i的子节点
dp[i][0]=sum(dp[k][1])由于本节点不放士兵,所以子节必须放士兵,不然这条边将没有士兵看守,把子节点放士兵的加起来
最后所有数量最少的士兵取dp[0][0]和dp[0][1]的较小值

#include<iostream>
#include<vector>
using namespace std;
const int maxn=1600;
int dp[maxn][2];
int n;

vector<int> tree[maxn];
int min(int a,int b){
    if(a<b)return a;
    else return b;
}
void dfs(int old,int now){
    dp[now][0]=0;
    dp[now][1]=1;
    int len=tree[now].size();
    int i;
    for(i=0;i<len;i++){
        int t=tree[now].at(i);
        if(t!=old){
            dfs(now,t);
            dp[now][0]+=dp[t][1];
            dp[now][1]+=min(dp[t][0],dp[t][1]); 
            } 
        }
    }

int main(){
    int a,b,j,x;
    while(cin>>n){
        int i;
        for(i=0;i<n;i++)
            tree[i].clear();
        for(i=0;i<n;i++){

            scanf("%d:(%d)",&a,&b);
            for(j=0;j<b;j++){
                cin>>x;
                tree[a].push_back(x);
                tree[x].push_back(a);
            }
        }
        dfs(-1,0);
        cout<<min(dp[0][0],dp[0][1])<<endl;
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值