HDU1398 Square Coins(母函数,无限制的)

Problem Description

People in Silverland use square coins. Not only they have square
shapes but also their values are square numbers. Coins with values of
all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit
coins, 9-credit coins, …, and 289-credit coins, are available in
Silverland. There are four combinations of coins to pay ten credits:

ten 1-credit coins, one 4-credit coin and six 1-credit coins, two
4-credit coins and two 1-credit coins, and one 9-credit coin and one
1-credit coin.

Your mission is to count the number of ways to pay a given amount
using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an
amount to be paid, followed by a line containing a zero. You may
assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer
representing the number of combinations of coins should be output. No
other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

思路

有面值为 12,22,32,...,172 1 2 , 2 2 , 3 2 , . . . , 17 2 的硬币无限个,然后给出一个n,问有多少种组成方法可以组成n.

无限制的母函数问题, (1+x+x2+...+xk)(1+x2+x4+...+x2k)...(1+x17+x34+...+x17k) ( 1 + x + x 2 + . . . + x k ) ∗ ( 1 + x 2 + x 4 + . . . + x 2 k ) ∗ . . . ∗ ( 1 + x 17 + x 34 + . . . + x 17 k ) 展开后 xn x n 次方项的系数就是答案

代码

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
#define inf 1000000
#define mem(a,b) memset(a,b,sizeof(a))
const int N=1000+7;
int a[N],b[N];
int v[N];
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1; i<=17; i++)
            v[i]=i*i;
        mem(a,0);
        a[0]=1;
        for (int i=1; i<=17; i++)
        {
            mem(b,0);
            for (int j=0; j*v[i]<=n; j++) //循环每个因子的每一项
                for (int k=0; k+j*v[i]<=n; k++) //循环a的每个项
                    b[k+j*v[i]]+=a[k];//把结果加到对应位
            memcpy(a,b,sizeof(b));//b赋值给a
        }
        printf("%d\n",a[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值