Largest Rectangle in a Histogram(贪心)

Largest Rectangle in a Histogram


A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

在这里插入图片描述

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, …, hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
大致题意
输入n个宽为1相连矩形的高,求这些矩形能形成的最大矩形面积。
思路:
观察可以得出当第i-1个比第i个高的时候 比第i-1个高的一定比第i个高
于是可以用到动态规划的思想,令l[i]表示包括i在内比i高的连续序列中最左边一个的编号 r[i] 为最右边一个的编号。所求的即为: max((r[i]-l[i]+1)*a[i]) ;
代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100010],l[100010],r[100010];
int main()
{
    int i,j,n;
    while(~scanf("%d",&n)&&n)
    {
        long long ans=0;
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            l[i]=r[i]=i;
            while(l[i]>0&&a[l[i]-1]>=a[i])
            {
                l[i]=l[l[i]-1];
            }
        }
        for(i=n-1;i>=0;i--)
        {
            while(r[i]<n-1&&a[r[i]+1]>=a[i])
            {
                r[i]=r[r[i]+1];
            }
        }
        for(int i=0; i<n; i++)
        {
            long long s=(long long)a[i]*(r[i]-l[i]+1);
            ans=max(ans,s);
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值