POJ 2248 Addition Chains

Description

An addition chain for n is an integer sequence with the following four properties:
a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.
Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.
Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.
Sample Input

5
7
12
15
77
0
Sample Output

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77


由于数据不大,可以枚举数列长度,迭代加深搜索。
由于数列严格单调递增,所以可以记录末尾值剪枝。


#include<iostream>
#include<cstdio>
using namespace std;
int n,dep,a[101];
bool dfs(int cur,int lst)
{
    if(cur==dep)
    {
        if(a[cur-1]==n)
            return 1;
        return 0;
    }
    for(int i=0;i<=cur-1;i++)
        for(int j=i;j<=cur-1;j++)
        {
            if(a[i]+a[j]>n)
                break;
            if(a[i]+a[j]>lst)
            {
                a[cur]=a[i]+a[j];
                if(dfs(cur+1,a[cur]))
                    return 1;
            }
        }
    return 0;
}
int main()
{
    a[0]=1;
    while(scanf("%d",&n)&&n)
    {
        for(int i=1;;i++)
        {
            dep=i;
            if(dfs(1,1))
            {
                for(int j=0;j<=i-1;j++)
                    printf("%d ",a[j]);
                printf("\n");
                break;
            }
        }
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值