1013 Battle Over Cities (25 分)dfs求最大连通分量个数

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway
city​2-city3.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题意:给出城市的数量,城市中的道路数量,和查询次数,当有一个城市被炸毁时,其相应的路也被切断,问需要把剩下的几个城市连通需要添加几条路
思路:添加的最少的路线,就是他们的连通分量数-1,因为当a个互相分立的连通分量需要变为连通图的时候,只需要添加a-1个路线,就能让他们相连。所以这道题就是求去除了某个结点之后其他的图所拥有的连通分量数。
对于被炸毁的城市,直接用visit数组设置该点为true,去除这个城市标记,即表示已经访问过,在做深度优先遍历的时候,需要深搜未访问的点和亮点之间需要连通,就能求出所有的连通分量个数,但是在每次炸毁一个城市的时候都需要添加fill(visit, visit + 1010, false)进行数组统一操作,不这样做会错。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

int a[1010][1010];
bool visit[1010] = {false};
int n;

void dfs(int s) {
	visit[s] = true;
	for(int i = 1;i <= n;i++) {
		if(visit[i] == false && a[s][i] == 1) {
			dfs(i);
		}		
	}
}

int main() {
	int m,k;
	int c,d;
	scanf("%d%d%d",&n,&m,&k);
	for(int i = 0;i < m;i++) {
		scanf("%d%d",&c,&d);
		a[c][d] = a[d][c] = 1;
	}
	int id;
	for(int i = 0;i < k;i++) {
		fill(visit, visit + 1010, false);
		scanf("%d",&id);
		visit[id] = true;
		int cnt = 0;
		for(int j = 1;j <= n;j++) {
			if(visit[j] == false) {
				dfs(j);
				cnt++;
			}
		}
		printf("%d\n",cnt - 1);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值