1070 Mooncake (25 分)贪心算法 分月饼

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region’s culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

题意:先输入有月饼的种类数,和月饼的最大需求数,再输入每种月饼的总数量和月饼的总价,求出在满足最大需求数的情况下最大能卖多少钱
思路:贪心算法,结构体定义的时候最好三个变量,月饼的总数量,总价格,单价都定义为double类型,然后如果当前种类月饼的数量满足小于等于d的话,就加上该类月饼的总价格,否则就按照剩下的数量乘以单价加上总价格。

#include<iostream>
#include<cstdio>
#include<stack> 
#include<queue>
#include<vector>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<set>
#include<map>

using namespace std;

struct node {
	double number;
	double price;
	double unit;
};

bool cmp(node a,node b) {
	return a.unit > b.unit;	
}

int main() {
	int n,d;
	scanf("%d%d",&n,&d);
	vector<node> v(n);
	for(int i = 0;i < n;i++) {
		scanf("%lf",&v[i].number);
	}	
	for(int i = 0;i < n;i++) {
		scanf("%lf",&v[i].price);
	}
	for(int i = 0;i < n;i++) {
		v[i].unit = v[i].price / v[i].number;
	}
	sort(v.begin(),v.end(),cmp);
	double result = 0.0;
	for(int i = 0;i < n;i++) {
		if(v[i].number <= d) {
			result = result + v[i].price;
		} else {
			result = result + v[i].unit * d;
			break;
		}
		d = d - v[i].number;
	}
	printf("%.2lf\n",result);
	return 0;	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值