九度OJ 1029 魔咒词典

题目描述:
    哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。

    给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
输入:

    首先列出词典中不超过100000条不同的魔咒词条,每条格式为:

    [魔咒] 对应功能

    其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
    词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:
    每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
样例输入:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
   
   
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
样例输出:
light the wand
accio
what?
what?

    
    
这道题写得混乱至极,参考了这位学姐的代码http://blog.csdn.net/abcjennifer/article/details/7256220
不想用gets用了getline,既有C也有C++,既有string也有char数组。。。以后再改
主要用了二分查找来避免超时,再就是字符串处理还很生疏
#include <string>
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
 
using namespace std;
 
struct CUR
{
    char name[25];
    char func[85];
}Dict[2][100010];
 
bool cmp1(CUR a, CUR b)
{
    int tmp = strcmp(a.name,b.name);
    return tmp < 0;
}
 
bool cmp2(CUR a, CUR b)
{
    int tmp = strcmp(a.func,b.func);
    return tmp < 0;
}
 
void search(int row, const char * s, int cnt)
{
    int l = 0, r = cnt;
    if(row == 0)
    {
        while(l <= r)
        {
            int m = (l + r) / 2;
            if(strcmp(Dict[0][m].name,s) == 0)
            {
                printf("%s\n",Dict[0][m].func);
                return;
            }
            else if(strcmp(Dict[0][m].name,s) < 0)
                l = m + 1;
            else
                r = m - 1;
        }
    }
    else
    {
        while(l <= r)
        {
            int m = (l + r) / 2;
            if(strcmp(Dict[1][m].func,s) == 0)
            {
                for(int i = 1; i < strlen(Dict[1][m].name)-1; i++)
                    printf("%c",Dict[1][m].name[i]);
                printf("\n");
                return;
            }
            else if(strcmp(Dict[1][m].func,s) < 0)
                l = m + 1;
            else
                r = m - 1;
        }
    }
    printf("what?\n");
    return;
}
 
int main()
{
    //freopen("1029in.txt","r",stdin);
    string buf;
    int cnt = 0;
    while(getline(cin,buf))
    {       
        if(buf == "@END@")
            break;
        char str1[25], str2[85];
        int len = buf.size();
        int i = 0, j = 0;
        while(buf[i] != ']')
            str1[j++] = buf[i++];
        str1[j++] = buf[i++];
        str1[j] = '\0';
        i++; j = 0;
        while(i < len)
            str2[j++] = buf[i++];
        str2[j] = '\0';
        strcpy(Dict[0][cnt].name,str1);
        strcpy(Dict[0][cnt].func,str2);
        strcpy(Dict[1][cnt].name,str1);
        strcpy(Dict[1][cnt].func,str2);
        cnt++;
    }
 
    sort(Dict[0],Dict[0]+cnt,cmp1);
    sort(Dict[1],Dict[1]+cnt,cmp2);
     
    //for(int j = 0; j < cnt; j++)
    //  printf("%s %s\n",Dict[1][j].name,Dict[1][j].func);
     
    int N;
    scanf("%d",&N);
    getchar();
    while(N--)
    {
        string str;
        getline(cin,str);
        // printf("%s\n",str.c_str());
        if(str[0] == '[')
        {
            search(0,str.c_str(),cnt-1);
        }
        else
        {
            search(1,str.c_str(),cnt-1);
        }
    }
    return 0;
}
/**************************************************************
    Problem: 1029
    User: ronixy
    Language: C++
    Result: Accepted
    Time:40 ms
    Memory:23020 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值