7-13 二叉搜索树的结构 (30 分)

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。
输入格式:

输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

  • A is the root,即"A是树的根";
  • A and B are siblings,即"A和B是兄弟结点";
  • A is the parent of B,即"A是B的双亲结点";
  • A is the left child of B,即"A是B的左孩子";
  • A is the right child of B,即"A是B的右孩子"
  • A and B are on the same level,即"A和B在同一层上"。

题目保证所有给定的整数都在整型范围内。

输出格式:

对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。

输入样例:

5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3

输出样例:

Yes
Yes
Yes
Yes
Yes
No
No
No

看着柳神的代码学习的,tree存储树中结点,Find用来存储某一个值在树中存储的位置,这里用map存储,数组的话放不下;
建好树后,对输入的分析就是一个简单模拟

AC代码:

#include<bits/stdc++.h>
using namespace std;
struct node{
	int num, lchild = -1, rchild = -1, level, pa = -1;
}tree[210];
int n, m, x, a, b, res, root = 1, cnt;
map<int, int> Find;
string c;
void insert(int x){
	int u = root;
	while(tree[u].num != x){
		if(x < tree[u].num){
			if(tree[u].lchild == -1){
				tree[cnt].num = x;
				tree[cnt].level = tree[u].level + 1;
				tree[cnt].pa = u;
				tree[u].lchild = cnt;
			}
			u = tree[u].lchild;
		}else{
			if(tree[u].rchild == -1){
				tree[cnt].num = x;
				tree[cnt].level = tree[u].level + 1;
				tree[cnt].pa = u;
				tree[u].rchild = cnt;
			}
			u = tree[u].rchild;
		}
	}
}
int main(){
	cin >> n >> x;
	tree[++cnt].num = x;
	Find[x] = cnt;
	for(int i = 1;i < n;i++)	cin >> x, Find[x] = ++cnt, insert(x); 
	cin >> m;
	while(m--){
		res = 0;
		cin >> a >> c;
		if(c == "is"){
			cin >> c >> c;
			if(c == "root"){
				if(Find[a] == root)	res = 1;
			}else if(c == "parent"){
				cin >> c >> b;
				if(tree[Find[b]].pa == Find[a])	res = 1;
			}else if(c == "left"){
				cin >> c >> c >> b;
				if(tree[Find[b]].lchild == Find[a])	res = 1;
			}else{
				cin >> c >> c >> b;
				if(tree[Find[b]].rchild == Find[a])	res = 1;
			}
		}else{
			cin >> b >> c >> c;
			if(c == "siblings"){
				if(Find[a] && Find[b] && tree[Find[a]].pa == tree[Find[b]].pa)	res = 1;
			}else{
				cin >> c >> c >> c;
				if(Find[a] && Find[b] && tree[Find[a]].level == tree[Find[b]].level)	res = 1;
			}
		}
		if(res)	puts("Yes");
		else	puts("No");
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

China-Rookie-LSJ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值