This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
1 <= K <= 10和0 <= NK < ... < N2 < N1 <=1000 只说明指数是整数,没说系数不能是负数,坑爹
#include <stdio.h>
#include <stdlib.h>
#include <stdbool.h>
#include <math.h>
#define ARRAYSIZE 1001
#define MAXSIZE 2001
#define INF 0x3f3f3f
#define ZERO 0.05
int main()
{
int aLen, bLen, cLen;
double a[ARRAYSIZE] = {0};
double b[ARRAYSIZE] = {0};
int i, j;
float c[MAXSIZE] = {0};
int exponent;
double coefficient;
cLen = 0;
scanf("%d", &aLen);
for(i=0; i<aLen; i++)
{
scanf("%d %lf", &exponent, &coefficient);
a[exponent] += coefficient;
}
scanf("%d", &bLen);
for(i=0; i<bLen; i++)
{
scanf("%d %lf", &exponent, &coefficient);
b[exponent] += coefficient;
}
for(i=0; i<ARRAYSIZE; i++)
{
//if(a[i]>0) //为了省几个循环,我在这里曾经加了个条件,表示系数大于0才可以做运算,哪知道用例1死活通不过
//{
for(j=0; j<ARRAYSIZE; j++)
{
//if(b[j]>0) //然后我把这个判断注释掉之后就通过了
//{
exponent = i+j;
coefficient = a[i] * b[j];
c[exponent] += coefficient;
// printf("\n Test:a[%d]:%.1f\n", i, a[i]);
// printf(" Test:b[%d]:%.1f\n", j, b[j]);
// printf(" Test:c[%d]:%.1f\n",exponent, coefficient);
//}
}
//}
}
for(i=0; i<MAXSIZE; i++)
{
if(fabs(c[i])>=ZERO)
{
cLen++;
}
}
printf("%d", cLen);
if(cLen==0)
printf(" 0.0");
for(i=MAXSIZE-1; i>=0; i--)
{
if(fabs(c[i])>=ZERO)
{
printf(" %d %.1f", i, c[i]);
}
}
system("pause");
}