Sum of Consecutive Prime Numbers

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20.

Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2

3

17

41

20

666

12

53

0

Sample Output

1

1

2

3

0

0

1

2

 两种思路 第一种为查找,本人不是很喜欢

#include<stdio.h>
#include<math.h>
int isprime(int n)
{
    int i;
    if(n==2)
    return 1;
    else 
    {
        for(i=2;i<=sqrt(n)+1;i++)
        {
            if(n%i==0)
            {
                return 0;
            }
        }
    }
    return 1;
}
int main()
{
    int prime[2500],len=0,i;
    for(i=2;i<10000;i++)
    {
        if(isprime(i))
        {
            prime[len++]=i;    //将所有质数放于表prime中,之后再逐项连续求和,看是否能等于n
        }
    }
    int n,cnt,j,sum;
    while(scanf("%d",&n)&&n)
    {
        cnt=0;                //cnt计数
        for(i=0;i<len;i++)    
        {
            sum=0;            //sum用于和n作比较
            for(j=i;j<len;j++)
            {
                sum+=prime[j];
                if(sum>n)
                break;
                else if(sum==n)
                cnt++;    
            }
        }
        printf("%d",cnt);
    }
    return 0;
}

既然已经想到打质数表,为啥不想着连答案表一起打了呢?

于是乎,我本人更偏向于第二种做法

#include<stdio.h>
int main()
{
    int flag[10000]={0},prime[2500],i,j,answer[10000]={0};
    int len=0;
    for(i=2;i<10000;i++)
    {
        if(flag[i]==0)
        {
            prime[len++]=i;
            for(j=2*i;j<10000;j+=i)
            {
                flag[j]=1;
            }
        }
    }
    int sum=0;
    int n;
    for(i=0;i<len;i++)
    {
        sum=0;
        for(j=i;j<len;j++)
        {
            sum+=prime[j];
			if(sum>10000)     //注意这里有个判断,如果不判断,可能造成数组溢出而崩掉
			{
				break;
			}
            answer[sum]++;
        }
    }
    while(scanf("%d",&n)&&n)
    {
        printf("%d",answer[n]);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值