POJ 2001  Shortest Prefixes

Shortest Prefixes
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 7213Accepted: 3019

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate 
cart 
carburetor 
caramel 
caribou 
carbonic 
cartilage 
carbon 
carriage 
carton 
car 
carbonate

Sample Output

carbohydrate carboh 
cart cart 
carburetor carbu 
caramel cara 
caribou cari 
carbonic carboni 
cartilage carti 
carbon carbon 
carriage carr 
carton carto 
car car 
carbonate carbona

Source

字典数,把路径标记一下,只要找到第一个属于他自己的路径就返回长度
代码:
C语言临时自用代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef  struct  point {
        struct  point  * child [ 26 ];
        int  flag;
} node , * Lnode;
int  m = sizeof( node);
char  str [ 1008 ][ 25 ];
Lnode  newnode()
{
        Lnode  p;
        int  i;
      p =( Lnode) malloc( m);
        for( i = 0; i < 26; i ++)
              p -> child [ i ] = NULL;
      p -> flag = 0;
        return  p;
}
void  Build( char  str1 [ 25 ], Lnode  tree)
{
        Lnode  p ,s;
        int  i;
      p = tree;
        for( i = 0; str1 [ i ]; i ++)
        {
                if(p -> child [ str1 [ i ] - 'a' ] == NULL)
                {
                      s = newnode();
                      p -> child [ str1 [ i ] - 'a' ] =s;
                      p =s;
                }
                else  p =p -> child [ str1 [ i ] - 'a' ];
              p -> flag ++;
        }
}
int  search( char  str1 [ 25 ], Lnode  tree)
{
        Lnode  p;
        int  n = 0 , i;
      p = tree;
        for( i = 0; str1 [ i ]; i ++)
        {
              p =p -> child [ str1 [ i ] - 'a' ];
              n ++;
                if(p -> flag == 1) return  n;
        }
        return  n;
}
int  main()
{
        int  i = 0 , j ,n , k;
        Lnode  tree;
        tree = newnode();
        while( scanf( "%s" , str [ i ]) != EOF)
        {
                Build( str [ i ], tree);
                i ++;
        }
        for( j = 0; j < i; j ++)
        {
                printf( "%s " , str [ j ]);
              n = search( str [ j ], tree);
                for( k = 0; k <n; k ++)
                        printf( "%c" , str [ j ][ k ]);
                printf( " \n ");
        }
        return  0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值